summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-07-04 21:44:34 +0200
committerSam James <sam@gentoo.org>2022-07-05 00:23:39 +0100
commit400298c4db1d19f1d1bdcdfdcbca688563c29a02 (patch)
tree97f62998e843095a72a092dfb21c87860f2e814f /app-forensics
parentapp-shells/zsh: fix docs building on live ebuild (diff)
downloadgentoo-400298c4db1d19f1d1bdcdfdcbca688563c29a02.tar.gz
gentoo-400298c4db1d19f1d1bdcdfdcbca688563c29a02.tar.bz2
gentoo-400298c4db1d19f1d1bdcdfdcbca688563c29a02.zip
app-forensics/yara: don't install static libraries with FEATURES=test
Closes: https://bugs.gentoo.org/856085 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26224 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/yara-4.2.0-r1.ebuild2
-rw-r--r--app-forensics/yara/yara-4.2.1.ebuild2
-rw-r--r--app-forensics/yara/yara-4.2.2.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/app-forensics/yara/yara-4.2.0-r1.ebuild b/app-forensics/yara/yara-4.2.0-r1.ebuild
index 55e7f11069d5..a4761519106a 100644
--- a/app-forensics/yara/yara-4.2.0-r1.ebuild
+++ b/app-forensics/yara/yara-4.2.0-r1.ebuild
@@ -53,5 +53,5 @@ src_install() {
# TODO: Allow tests to work against dyn. lib rather than building
# statically just for tests.
- find "${ED}" -name '*.a' -o -name '*.la' -delete || die
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
}
diff --git a/app-forensics/yara/yara-4.2.1.ebuild b/app-forensics/yara/yara-4.2.1.ebuild
index 55e7f11069d5..a4761519106a 100644
--- a/app-forensics/yara/yara-4.2.1.ebuild
+++ b/app-forensics/yara/yara-4.2.1.ebuild
@@ -53,5 +53,5 @@ src_install() {
# TODO: Allow tests to work against dyn. lib rather than building
# statically just for tests.
- find "${ED}" -name '*.a' -o -name '*.la' -delete || die
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
}
diff --git a/app-forensics/yara/yara-4.2.2.ebuild b/app-forensics/yara/yara-4.2.2.ebuild
index 6370d398ea67..cf8905b87957 100644
--- a/app-forensics/yara/yara-4.2.2.ebuild
+++ b/app-forensics/yara/yara-4.2.2.ebuild
@@ -53,5 +53,5 @@ src_install() {
# TODO: Allow tests to work against dyn. lib rather than building
# statically just for tests.
- find "${ED}" -name '*.a' -o -name '*.la' -delete || die
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
}