summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-18 19:08:42 +0100
committerSam James <sam@gentoo.org>2022-08-18 19:12:02 +0100
commit82d8bff402dc1601d6f2a3254883fc90267191f3 (patch)
tree0abc624a463423feeb80d1154d856664ccfb9800 /app-forensics
parentdev-python/ensurepip-setuptools: add 65.1.0 (diff)
downloadgentoo-82d8bff402dc1601d6f2a3254883fc90267191f3.tar.gz
gentoo-82d8bff402dc1601d6f2a3254883fc90267191f3.tar.bz2
gentoo-82d8bff402dc1601d6f2a3254883fc90267191f3.zip
app-forensics/libewf: fix build with OpenSSL 3
Closes: https://bugs.gentoo.org/805188 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/files/libewf-20171104-openssl-3.patch27
-rw-r--r--app-forensics/libewf/libewf-20171104-r2.ebuild66
2 files changed, 93 insertions, 0 deletions
diff --git a/app-forensics/libewf/files/libewf-20171104-openssl-3.patch b/app-forensics/libewf/files/libewf-20171104-openssl-3.patch
new file mode 100644
index 000000000000..2d30da7042f8
--- /dev/null
+++ b/app-forensics/libewf/files/libewf-20171104-openssl-3.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/805188
+https://github.com/libyal/libewf/commit/033ea5b4e5f8f1248f74a2ec61fc1be183c6c46b
+--- a/ewftools/ewftools_output.c
++++ b/ewftools/ewftools_output.c
+@@ -238,12 +238,20 @@ void ewfoutput_version_detailed_fprint(
+ LIBHMAC_VERSION_STRING );
+
+ #if defined( HAVE_LIBCRYPTO )
++#if defined( SHLIB_VERSION_NUMBER )
+ fprintf(
+ stream,
+ " (libcrypto %s)",
+ SHLIB_VERSION_NUMBER );
+-#endif
+-#endif
++#elif defined( OPENSSL_VERSION_MAJOR ) && defined( OPENSSL_VERSION_MINOR )
++ fprintf(
++ stream,
++ " (libcrypto %d.%d)",
++ OPENSSL_VERSION_MAJOR,
++ OPENSSL_VERSION_MINOR );
++#endif
++#endif
++#endif
+
+ #if defined( HAVE_LIBODRAW ) || defined( HAVE_LOCAL_LIBODRAW )
+ fprintf(
diff --git a/app-forensics/libewf/libewf-20171104-r2.ebuild b/app-forensics/libewf/libewf-20171104-r2.ebuild
new file mode 100644
index 000000000000..8f9c065718a9
--- /dev/null
+++ b/app-forensics/libewf/libewf-20171104-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="https://github.com/libyal/libewf"
+SRC_URI="https://github.com/libyal/libewf/releases/download/${PV}/${PN}-experimental-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~x86"
+# Upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python unicode"
+IUSE="bfio bzip2 debug +fuse nls +ssl static-libs +uuid unicode zlib"
+
+# Uses bundled libbfio until tree version is bumped
+RDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ fuse? ( sys-fs/fuse:0= )
+ nls? (
+ virtual/libintl
+ virtual/libiconv
+ )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+# Issues finding test executables
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-openssl-3.patch
+)
+
+src_configure() {
+ local econfargs=(
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ $(use_enable debug verbose-output)
+ $(use_enable debug debug-output)
+ $(use_enable unicode wide-character-type)
+ $(use_with bfio libbfio)
+ $(use_with zlib)
+ $(use_with bzip2)
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}"/usr -name '*.la' -delete || die
+ fi
+}