summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-05-14 18:18:43 +0200
committerMichael Palimaka <kensington@gentoo.org>2019-05-15 20:28:53 +1000
commitbafa87b1cfd4dc9c6605b19763f93aab26576a25 (patch)
treefd1e3f85058d6d51b73eb7df94a43152fc465f40 /app-forensics
parentapp-forensics/examiner: fix LICENSE (diff)
downloadgentoo-bafa87b1cfd4dc9c6605b19763f93aab26576a25.tar.gz
gentoo-bafa87b1cfd4dc9c6605b19763f93aab26576a25.tar.bz2
gentoo-bafa87b1cfd4dc9c6605b19763f93aab26576a25.zip
app-forensics/examiner: EAPI7, update ebuild
Closes: https://bugs.gentoo.org/685962 Closes: https://github.com/gentoo/gentoo/pull/11997 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/examiner/examiner-0.5-r3.ebuild36
-rw-r--r--app-forensics/examiner/files/examiner-0.5-perl.patch8
2 files changed, 40 insertions, 4 deletions
diff --git a/app-forensics/examiner/examiner-0.5-r3.ebuild b/app-forensics/examiner/examiner-0.5-r3.ebuild
new file mode 100644
index 000000000000..71a49ad68463
--- /dev/null
+++ b/app-forensics/examiner/examiner-0.5-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utilizes the objdump command to disassemble and comment foreign binaries"
+HOMEPAGE="http://www.academicunderground.org/examiner/"
+SRC_URI="http://www.academicunderground.org/examiner/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ default
+ # Do not install docs through Makefile wrt bug #241256
+ sed -i -e '/$(DOC)/d' Makefile || die 'sed failed'
+ eapply "${FILESDIR}"/${P}-perl.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/bin /usr/share/${PN} /usr/share/man/man1
+
+ emake \
+ MAN="${D}/usr/share/man/man1" \
+ BIN="${D}/usr/bin" \
+ SHARE="${D}/usr/share/examiner" \
+ install
+
+ dodoc docs/{README*,BUGS,CHANGELOG,TODO,TUTORIAL}
+ dodoc -r utils
+}
diff --git a/app-forensics/examiner/files/examiner-0.5-perl.patch b/app-forensics/examiner/files/examiner-0.5-perl.patch
index ee24bfd9c079..e9e838692539 100644
--- a/app-forensics/examiner/files/examiner-0.5-perl.patch
+++ b/app-forensics/examiner/files/examiner-0.5-perl.patch
@@ -1,5 +1,5 @@
---- ./os/linux/examiner_hashes.pl.orig 2005-05-22 10:39:56.000000000 +1000
-+++ ./os/linux/examiner_hashes.pl 2005-05-22 10:40:11.000000000 +1000
+--- a/os/linux/examiner_hashes.pl.orig 2005-05-22 10:39:56.000000000 +1000
++++ b/os/linux/examiner_hashes.pl 2005-05-22 10:40:11.000000000 +1000
@@ -1,6 +1,6 @@
$loaded_library=1;
@@ -17,8 +17,8 @@
1 => "SOCKET",
2 => "BIND",
3 => "CONNECT",
---- os/bsd/examiner_hashes.pl.orig 2005-05-22 10:45:39.000000000 +1000
-+++ os/bsd/examiner_hashes.pl 2005-05-22 10:45:58.000000000 +1000
+--- a/os/bsd/examiner_hashes.pl.orig 2005-05-22 10:45:39.000000000 +1000
++++ b/os/bsd/examiner_hashes.pl 2005-05-22 10:45:58.000000000 +1000
@@ -1,6 +1,6 @@
$loaded_library=1;