summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-24 23:25:41 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-25 00:02:34 +0100
commitc26f2a2ef5de53b65d8567cce755828d3cbbca7b (patch)
tree5b541cec416bf6d0d67271f68771dd49c677e86a /app-forensics
parentnet-dialup/freeradius-client: keyword 1.1.7-r1 for ~riscv (diff)
downloadgentoo-c26f2a2ef5de53b65d8567cce755828d3cbbca7b.tar.gz
gentoo-c26f2a2ef5de53b65d8567cce755828d3cbbca7b.tar.bz2
gentoo-c26f2a2ef5de53b65d8567cce755828d3cbbca7b.zip
app-forensics/zzuf: update EAPI 7 -> 8, add multilib support
Also drop USE=static-libs, installing static versions of libraries whose primary purpose is to be preloaded is rather pointless. Closes: https://bugs.gentoo.org/546796 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/zzuf/zzuf-0.15-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-forensics/zzuf/zzuf-0.15-r2.ebuild b/app-forensics/zzuf/zzuf-0.15-r2.ebuild
new file mode 100644
index 000000000000..8e8009ec5c58
--- /dev/null
+++ b/app-forensics/zzuf/zzuf-0.15-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Transparent application input fuzzer"
+HOMEPAGE="http://caca.zoy.org/wiki/zzuf"
+SRC_URI="https://github.com/samhocevar/zzuf/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+# Uses dlopen hack to hijack many libc functions.
+# Fails 2 tests with sandbox enabled: check-zzuf-A-autoinc check-utils
+RESTRICT="test"
+
+DOCS=( AUTHORS COPYING TODO )
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}