summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2018-04-01 11:54:14 +0100
committerAkinori Hattori <hattya@gentoo.org>2018-05-07 21:51:56 +0900
commit7e17670a886d15ab6a0ba40c906cbbe0dce5d066 (patch)
tree7409b3e53553252a272cd885046ca02a160e7646 /app-i18n/fbterm/fbterm-1.7-r5.ebuild
parentdev-libs/libotf: 0.9.16 version bump. Use pkg-config to find freetype (diff)
downloadgentoo-7e17670a886d15ab6a0ba40c906cbbe0dce5d066.tar.gz
gentoo-7e17670a886d15ab6a0ba40c906cbbe0dce5d066.tar.bz2
gentoo-7e17670a886d15ab6a0ba40c906cbbe0dce5d066.zip
app-i18n/fbterm: fix file collision with sys-libs/ncurses-6.1
Bug: https://bugs.gentoo.org/648472 Closes: https://github.com/gentoo/gentoo/pull/7764 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-i18n/fbterm/fbterm-1.7-r5.ebuild')
-rw-r--r--app-i18n/fbterm/fbterm-1.7-r5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-i18n/fbterm/fbterm-1.7-r5.ebuild b/app-i18n/fbterm/fbterm-1.7-r5.ebuild
new file mode 100644
index 000000000000..a4b174a1f859
--- /dev/null
+++ b/app-i18n/fbterm/fbterm-1.7-r5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools fcaps
+
+DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
+HOMEPAGE="https://code.google.com/p/fbterm"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpm video_cards_vesa"
+
+RDEPEND="media-libs/fontconfig
+ media-libs/freetype:2
+ gpm? ( sys-libs/gpm )
+ video_cards_vesa? ( dev-libs/libx86 )
+ >=sys-libs/ncurses-6.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc6.patch
+ "${FILESDIR}"/${PN}-noterminfo.patch
+)
+
+FILECAPS=(
+ cap_sys_tty_config+ep usr/bin/${PN}
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gpm) \
+ $(use_enable video_cards_vesa vesa)
+}
+
+src_install() {
+ default
+
+ use filecaps || fperms u+s /usr/bin/${PN}
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ elog "${PN} won't work with vga16fb. You have to use other native"
+ elog "framebuffer drivers or vesa driver."
+ elog "See ${EPREFIX}/usr/share/doc/${P}/README for details."
+ elog
+ elog "To use ${PN}, ensure you are in video group."
+}