summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-10-19 22:47:40 +0200
committerMike Gilbert <floppym@gentoo.org>2017-10-23 13:24:41 -0400
commit9cf9419d826f0df2d59e63352799fadac5c1fedd (patch)
treeb1c45efd1f7f48ecf7cc1895e75b7cf5e5bc6943 /app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild
parentapp-i18n/fcitx-hangul: Version bump (0.3.1). (diff)
downloadgentoo-9cf9419d826f0df2d59e63352799fadac5c1fedd.tar.gz
gentoo-9cf9419d826f0df2d59e63352799fadac5c1fedd.tar.bz2
gentoo-9cf9419d826f0df2d59e63352799fadac5c1fedd.zip
app-i18n/fcitx-hangul: Add live ebuild.
Diffstat (limited to 'app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild b/app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild
new file mode 100644
index 000000000000..7fd3d0bc6476
--- /dev/null
+++ b/app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-hangul"
+fi
+
+DESCRIPTION="Korean Hangul input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-hangul"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ app-i18n/libhangul:=
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}