summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-06-13 22:37:13 +0200
committerMike Gilbert <floppym@gentoo.org>2018-06-13 17:07:35 -0400
commit4d9a4271b3180d3a1c4c6bda1f4ccb4d0bd74567 (patch)
treedf346e46f739b74d77629e9d6162eb921845e1d2 /app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
parentwww-client/chromium: stable channel bump (67.0.3396.87) (diff)
downloadgentoo-4d9a4271b3180d3a1c4c6bda1f4ccb4d0bd74567.tar.gz
gentoo-4d9a4271b3180d3a1c4c6bda1f4ccb4d0bd74567.tar.bz2
gentoo-4d9a4271b3180d3a1c4c6bda1f4ccb4d0bd74567.zip
app-i18n/fcitx-rime: Add "configuration_tool" USE flag.
https://github.com/fcitx/fcitx-rime/pull/40 https://github.com/fcitx/fcitx-rime/commit/af3897bb6c6f1eba14a908e77cfc3e1431e1e312
Diffstat (limited to 'app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild b/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
index 35443f12a6e1..74292ea23a01 100644
--- a/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
+++ b/app-i18n/fcitx-rime/fcitx-rime-4.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -22,20 +22,28 @@ fi
LICENSE="GPL-2"
SLOT="4"
KEYWORDS=""
-IUSE=""
+IUSE="+configuration_tool"
RDEPEND=">=app-i18n/fcitx-4.2.9:4
>=app-i18n/librime-1.0.0:=
app-i18n/rime-data
- virtual/libintl"
+ virtual/libintl
+ configuration_tool? (
+ >=app-i18n/fcitx-qt5-1.1:4
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+ configuration_tool? ( dev-qt/qtconcurrent:5 )"
DOCS=()
src_configure() {
local mycmakeargs=(
-DRIME_DATA_DIR="${EPREFIX}/usr/share/rime-data"
+ -DENABLE_QT5GUI=$(usex configuration_tool)
)
cmake-utils_src_configure