summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-27 11:57:55 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-27 15:57:01 -0400
commitdf512ab44cead49b030609ace0e9f09f486c2a7e (patch)
treee32e91c96642f2b972260717d75da6c12448b9be /app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
parentapp-i18n/fcitx-sayura: Call gnome2_icon_cache_update(). (diff)
downloadgentoo-df512ab44cead49b030609ace0e9f09f486c2a7e.tar.gz
gentoo-df512ab44cead49b030609ace0e9f09f486c2a7e.tar.bz2
gentoo-df512ab44cead49b030609ace0e9f09f486c2a7e.zip
app-i18n/fcitx-sayura: Version bump (0.1.2).
Diffstat (limited to 'app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild')
-rw-r--r--app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild b/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
new file mode 100644
index 000000000000..725a094c5115
--- /dev/null
+++ b/app-i18n/fcitx-sayura/fcitx-sayura-0.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-sayura"
+fi
+
+DESCRIPTION="Sinhala Sayura input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-sayura"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}