summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-27 12:18:32 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-27 15:57:01 -0400
commit48ab295ea279a2a3dfab31d9a006349c4318c80c (patch)
treea312d1c65721c5d4e445723a8e03e81d23fc3a8d /app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
parentapp-i18n/fcitx-sayura: Version bump (0.1.2). (diff)
downloadgentoo-48ab295ea279a2a3dfab31d9a006349c4318c80c.tar.gz
gentoo-48ab295ea279a2a3dfab31d9a006349c4318c80c.tar.bz2
gentoo-48ab295ea279a2a3dfab31d9a006349c4318c80c.zip
app-i18n/fcitx-unikey: Use ${Fcitx_major_version}.9999 version scheme for live ebuild.
Diffstat (limited to 'app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
new file mode 100644
index 000000000000..3b93c20b6ead
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-4.9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-unikey"
+fi
+
+DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-unikey"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="4"
+KEYWORDS=""
+IUSE="+macro-editor"
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ virtual/libintl
+ macro-editor? (
+ >=app-i18n/fcitx-4.2.8[qt4]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT=$(usex macro-editor)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}