summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-13 19:08:43 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-13 15:24:25 -0400
commite275f194950e7e84e97684aca1b0aa1d5a81cd18 (patch)
tree3c3cd689cc1a0d4214fcaf0b6006ce614c501a3c /app-i18n/fcitx/fcitx-4.2.9.2.ebuild
parentx11-wm/i3: Bump version to 4.14 (diff)
downloadgentoo-e275f194950e7e84e97684aca1b0aa1d5a81cd18.tar.gz
gentoo-e275f194950e7e84e97684aca1b0aa1d5a81cd18.tar.bz2
gentoo-e275f194950e7e84e97684aca1b0aa1d5a81cd18.zip
app-i18n/fcitx: In live ebuild, avoid downloading of data during src_compile() phase.
Diffstat (limited to 'app-i18n/fcitx/fcitx-4.2.9.2.ebuild')
-rw-r--r--app-i18n/fcitx/fcitx-4.2.9.2.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/app-i18n/fcitx/fcitx-4.2.9.2.ebuild b/app-i18n/fcitx/fcitx-4.2.9.2.ebuild
index 45eecfb57353..1bb5d6b08ddb 100644
--- a/app-i18n/fcitx/fcitx-4.2.9.2.ebuild
+++ b/app-i18n/fcitx/fcitx-4.2.9.2.ebuild
@@ -14,7 +14,11 @@ fi
DESCRIPTION="Fcitx (Flexible Context-aware Input Tool with eXtension) input method framework"
HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx"
if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
+ SRC_URI="https://download.fcitx-im.org/data/pinyin.tar.gz -> fcitx-data-pinyin.tar.gz
+ https://download.fcitx-im.org/data/table.tar.gz -> fcitx-data-table.tar.gz
+ https://download.fcitx-im.org/data/py_stroke-20121124.tar.gz -> fcitx-data-py_stroke-20121124.tar.gz
+ https://download.fcitx-im.org/data/py_table-20121124.tar.gz -> fcitx-data-py_table-20121124.tar.gz
+ https://download.fcitx-im.org/data/en_dict-20121020.tar.gz -> fcitx-data-en_dict-20121020.tar.gz"
else
SRC_URI="https://download.fcitx-im.org/${PN}/${P}_dict.tar.xz"
fi
@@ -70,6 +74,14 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog THANKS)
src_prepare() {
+ if [[ "${PV}" == "9999" ]]; then
+ ln -s "${DISTDIR}/fcitx-data-pinyin.tar.gz" src/im/pinyin/data/pinyin.tar.gz || die
+ ln -s "${DISTDIR}/fcitx-data-table.tar.gz" src/im/table/data/table.tar.gz || die
+ ln -s "${DISTDIR}/fcitx-data-py_stroke-20121124.tar.gz" src/module/pinyin-enhance/data/py_stroke-20121124.tar.gz || die
+ ln -s "${DISTDIR}/fcitx-data-py_table-20121124.tar.gz" src/module/pinyin-enhance/data/py_table-20121124.tar.gz || die
+ ln -s "${DISTDIR}/fcitx-data-en_dict-20121020.tar.gz" src/module/spell/dict/en_dict-20121020.tar.gz || die
+ fi
+
# https://github.com/fcitx/fcitx/issues/250
sed \
-e "/find_package(XkbFile REQUIRED)/i\\ if(ENABLE_X11)" \