summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-02-01 22:44:16 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-02-01 22:44:16 +0900
commitd7b2984d9823c11bcf2edff6d9410795c527d836 (patch)
tree691867b46cc63fae26e94d101e64661fc03a2e22 /app-i18n/ibus-anthy
parentdev-ml/spawn: 0.15.0 bump (diff)
downloadgentoo-d7b2984d9823c11bcf2edff6d9410795c527d836.tar.gz
gentoo-d7b2984d9823c11bcf2edff6d9410795c527d836.tar.bz2
gentoo-d7b2984d9823c11bcf2edff6d9410795c527d836.zip
app-i18n/ibus-anthy: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/Manifest1
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.14.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
index 8937da7c3f4f..9be8f195c6bd 100644
--- a/app-i18n/ibus-anthy/Manifest
+++ b/app-i18n/ibus-anthy/Manifest
@@ -1 +1,2 @@
DIST ibus-anthy-1.5.13.tar.gz 265252 BLAKE2B d35299dba3260b85f80f259e0a40ea1ec061ed8082b6e5c872eab6398b6242342b2ee4da0c3b191aa428ae2d8dc652b0e414fd0c9f7b93ca8dcd6303c0586b4d SHA512 058feb49b2fe50ae3ca959f4754b8070f3ebc1e6727fef4bca791aa45a23c95018000e2a8bca496d6592b052298a6fb2869a07c2cc56cc473c81cc437efa175b
+DIST ibus-anthy-1.5.14.tar.gz 267418 BLAKE2B a4da45588d8736f10ccf26af52179da85bd3a17a8f1fbdba622058d1eaed933b0102fe12357613574e377df323145487838c3f74c052c813462b435905d5c941 SHA512 4d06d4e177df62d22c61bf6ebfda04ddbf545ea1947d0c315e3dfe5e48d9ddc57e5fcc89919ae3b9f7430e6124a5dfb1295f4ca7362fbc35714d627f80fae6d8
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.14.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.14.ebuild
new file mode 100644
index 000000000000..d11f1e980d89
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.14.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}