summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/ibus-handwrite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/ibus-handwrite')
-rw-r--r--app-i18n/ibus-handwrite/Manifest1
-rw-r--r--app-i18n/ibus-handwrite/files/ibus-handwrite-link.patch13
-rw-r--r--app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild41
-rw-r--r--app-i18n/ibus-handwrite/ibus-handwrite-2.1.4.ebuild34
-rw-r--r--app-i18n/ibus-handwrite/metadata.xml8
5 files changed, 97 insertions, 0 deletions
diff --git a/app-i18n/ibus-handwrite/Manifest b/app-i18n/ibus-handwrite/Manifest
new file mode 100644
index 000000000000..9fdf3cb8eb43
--- /dev/null
+++ b/app-i18n/ibus-handwrite/Manifest
@@ -0,0 +1 @@
+DIST ibus-handwrite-2.1.4.tar.bz2 237980 SHA256 fa4ec0624e1ca904d8026fda75a26f0edd3ac6c781c28c03262e4c6ec52ceb34 SHA512 fca7129edb7433e7ea6df1ce67b3f27285fe102cc029a7a1bdb8ba0402407bd81724d1b14667d342ef41491acff03e9c152b748e4fee5387f315d4673c2964e6 WHIRLPOOL 13facb5d7c4a34586202cc1d6b46eb857aaf3649fb64ca44a5b367135860217c554d0cf48656096ac43cc3411b0466c9b2a468d9e2dc99ddac4d7729ff0ad6d9
diff --git a/app-i18n/ibus-handwrite/files/ibus-handwrite-link.patch b/app-i18n/ibus-handwrite/files/ibus-handwrite-link.patch
new file mode 100644
index 000000000000..bd73e4f41f46
--- /dev/null
+++ b/app-i18n/ibus-handwrite/files/ibus-handwrite-link.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 8625fe9..20fdd42 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -80,6 +80,8 @@ AS_IF([test "x${have_zinnia}" = "xyes" ],[
+ AM_CONDITIONAL(WITH_ZINNIA,[false])
+ ])
+
++AC_SEARCH_LIBS([atan2],[m])
++
+ # check ibus
+ PKG_CHECK_MODULES(IBUS, [
+ ibus-1.0 >= 1.3
diff --git a/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild b/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..56390185b44b
--- /dev/null
+++ b/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 autotools-utils multilib
+
+DESCRIPTION="hand write recognition/input using ibus IM engine"
+HOMEPAGE="http://code.google.com/p/ibus-handwrite/"
+SRC_URI="http://ibus-handwrite.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls +zinnia"
+
+RDEPEND="zinnia? ( app-i18n/zinnia app-i18n/zinnia-tomoe )
+ >=app-i18n/ibus-1.3.0
+ >=x11-libs/gtk+-2.10
+ x11-libs/gtkglext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-link.patch #bug #501954
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_enable zinnia)
+ $(use_with zinnia zinnia-tomoe "${EPREFIX}"/usr/$(get_libdir)/zinnia/model/tomoe)
+ )
+ autotools-utils_src_configure
+}
diff --git a/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4.ebuild b/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4.ebuild
new file mode 100644
index 000000000000..f5f7bd12611c
--- /dev/null
+++ b/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils python autotools-utils multilib
+
+DESCRIPTION="hand write recognition/input using ibus IM engine"
+HOMEPAGE="http://code.google.com/p/ibus-handwrite/"
+SRC_URI="http://ibus-handwrite.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls +zinnia"
+
+RDEPEND="zinnia? ( app-i18n/zinnia app-i18n/zinnia-tomoe )
+ >=app-i18n/ibus-1.3.0
+ >=x11-libs/gtk+-2.10
+ x11-libs/gtkglext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_enable zinnia)
+ $(use_with zinnia zinnia-tomoe "${EPREFIX}"/usr/$(get_libdir)/zinnia/model/tomoe)
+ )
+ autotools-utils_src_configure
+}
diff --git a/app-i18n/ibus-handwrite/metadata.xml b/app-i18n/ibus-handwrite/metadata.xml
new file mode 100644
index 000000000000..b705e0c6c1e7
--- /dev/null
+++ b/app-i18n/ibus-handwrite/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+<use>
+ <flag name="zinnia">Build with <pkg>app-i18n/zinnia</pkg> engine.</flag>
+</use>
+</pkgmetadata>