summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-14 21:44:51 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-14 21:44:51 +0900
commitd46211d53b0a5634ce6f61807fa53e06d776252b (patch)
tree492bbee6bd3f59274ab08aa2862a7046dbc46fcb /app-i18n/ibus-handwrite
parentapp-i18n/ibus-handwrite: fix blink (diff)
downloadgentoo-d46211d53b0a5634ce6f61807fa53e06d776252b.tar.gz
gentoo-d46211d53b0a5634ce6f61807fa53e06d776252b.tar.bz2
gentoo-d46211d53b0a5634ce6f61807fa53e06d776252b.zip
app-i18n/ibus-handwrite: fix build with Clang
Closes: https://bugs.gentoo.org/734216 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-handwrite')
-rw-r--r--app-i18n/ibus-handwrite/files/ibus-handwrite-nested-function.patch26
-rw-r--r--app-i18n/ibus-handwrite/ibus-handwrite-3.0.0-r1.ebuild1
2 files changed, 27 insertions, 0 deletions
diff --git a/app-i18n/ibus-handwrite/files/ibus-handwrite-nested-function.patch b/app-i18n/ibus-handwrite/files/ibus-handwrite-nested-function.patch
new file mode 100644
index 000000000000..96cbc118fa4f
--- /dev/null
+++ b/app-i18n/ibus-handwrite/files/ibus-handwrite-nested-function.patch
@@ -0,0 +1,26 @@
+--- a/src/UI_gtk.c
++++ b/src/UI_gtk.c
+@@ -74,6 +74,11 @@
+ return TRUE;
+ }
+
++static void clicked(GtkButton *button, IBusHandwriteEngine *engine)
++{
++ ibus_handwrite_engine_commit_text(engine,GPOINTER_TO_INT(g_object_get_data(G_OBJECT(button),"order")));
++}
++
+ static void regen_loopuptable(GtkWidget * widget, IBusHandwriteEngine * engine)
+ {
+ int i;
+@@ -98,11 +103,6 @@
+
+ gtk_widget_show(bt);
+
+- void clicked(GtkButton *button, IBusHandwriteEngine *engine)
+- {
+- ibus_handwrite_engine_commit_text(engine,GPOINTER_TO_INT(g_object_get_data(G_OBJECT(button),"order")));
+- }
+-
+ g_object_set_data(G_OBJECT(bt),"order",GINT_TO_POINTER(i));
+ g_signal_connect(bt,"clicked",G_CALLBACK(clicked),engine);
+
diff --git a/app-i18n/ibus-handwrite/ibus-handwrite-3.0.0-r1.ebuild b/app-i18n/ibus-handwrite/ibus-handwrite-3.0.0-r1.ebuild
index a57383c4952d..ffbab3234760 100644
--- a/app-i18n/ibus-handwrite/ibus-handwrite-3.0.0-r1.ebuild
+++ b/app-i18n/ibus-handwrite/ibus-handwrite-3.0.0-r1.ebuild
@@ -26,6 +26,7 @@ BDEPEND="virtual/pkgconfig
PATCHES=(
"${FILESDIR}"/${PN}-blink.patch
"${FILESDIR}"/${PN}-headers.patch
+ "${FILESDIR}"/${PN}-nested-function.patch
)
src_configure() {