summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-23 23:57:21 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-23 23:57:21 +0900
commit9567164531f9d9d4668dccfc8159c0426b341a2d (patch)
tree05ccf17ed9b6978eb459b1ee6b5ac269a197fb09 /app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r2.ebuild
parentapp-i18n/ibus-pinyin: update patch (diff)
downloadgentoo-9567164531f9d9d4668dccfc8159c0426b341a2d.tar.gz
gentoo-9567164531f9d9d4668dccfc8159c0426b341a2d.tar.bz2
gentoo-9567164531f9d9d4668dccfc8159c0426b341a2d.zip
app-i18n/ibus-pinyin: update to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r2.ebuild')
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r2.ebuild39
1 files changed, 17 insertions, 22 deletions
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r2.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r2.ebuild
index 59fec005f737..103c52c7ea0b 100644
--- a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r2.ebuild
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r2.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
+EAPI="6"
PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-inherit python-single-r1 eutils
+inherit python-single-r1
-DESCRIPTION="Chinese PinYin IMEngine for IBus Framework"
+DESCRIPTION="Chinese Pinyin and Bopomofo engines for IBus"
HOMEPAGE="https://github.com/ibus/ibus/wiki"
SRC_URI="https://ibus.googlecode.com/files/${P}.tar.gz"
@@ -16,35 +14,32 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="boost lua nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- >=app-i18n/ibus-1.4[python,${PYTHON_USEDEP}]
- dev-python/pygtk[${PYTHON_USEDEP}]
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
app-i18n/pyzy
- boost? ( >=dev-libs/boost-1.39 )
- lua? (
- >=dev-lang/lua-5.1
- <dev-lang/lua-5.2 )
+ dev-db/sqlite:3
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ boost? ( dev-libs/boost )
+ lua? ( =dev-lang/lua-5.1*:= )
nls? ( virtual/libintl )"
-
DEPEND="${RDEPEND}
- sys-apps/sed
+ dev-util/intltool
virtual/pkgconfig
- nls? ( >=sys-devel/gettext-0.16.1 )"
+ nls? ( sys-devel/gettext )"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-DOCS="AUTHORS ChangeLog NEWS README"
+PATCHES=( "${FILESDIR}"/${P}-content-type-method.patch )
src_prepare() {
- sed -i -e "s/python/${EPYTHON}/" setup/ibus-setup-pinyin.in || die
- epatch "${FILESDIR}"/${P}-content-type-method.patch
+ sed -i "s/python/${EPYTHON}/" setup/${PN/-/-setup-}.in
+
+ default
}
src_configure() {
econf \
$(use_enable boost) \
$(use_enable lua lua-extension) \
- $(use_enable nls) \
- --enable-english-input-mode
+ $(use_enable nls)
}