summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-09-04 21:20:47 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-09-04 21:20:47 +0900
commita4e18be02b70ead1b70c5f35646f17c2da3d693e (patch)
tree1ba45aa687331d3213e234cfcdc6c954b45b2d7f /app-i18n/ibus-table/ibus-table-1.9.21.ebuild
parentapp-arch/rar: Bump to v5.6.1 Beta 1 from 2018-09-03 (diff)
downloadgentoo-a4e18be02b70ead1b70c5f35646f17c2da3d693e.tar.gz
gentoo-a4e18be02b70ead1b70c5f35646f17c2da3d693e.tar.bz2
gentoo-a4e18be02b70ead1b70c5f35646f17c2da3d693e.zip
app-i18n/ibus-table: new upstream release
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-i18n/ibus-table/ibus-table-1.9.21.ebuild')
-rw-r--r--app-i18n/ibus-table/ibus-table-1.9.21.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/ibus-table-1.9.21.ebuild b/app-i18n/ibus-table/ibus-table-1.9.21.ebuild
new file mode 100644
index 000000000000..9552ac56f2b1
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.9.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}