summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-05-27 21:42:43 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-05-27 21:42:43 +0900
commit09ec0b7f53c00b7a400d0ca58c87ac3234c04d58 (patch)
tree2b901818e6b854c7503425ae225aef32ce311183 /app-i18n/ibus-typing-booster
parentmedia-libs/compface: fix configure (diff)
downloadgentoo-09ec0b7f53c00b7a400d0ca58c87ac3234c04d58.tar.gz
gentoo-09ec0b7f53c00b7a400d0ca58c87ac3234c04d58.tar.bz2
gentoo-09ec0b7f53c00b7a400d0ca58c87ac3234c04d58.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index b29624f5cd3e..3c2514d74b21 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.8.2.tar.gz 8161995 BLAKE2B 79c7bacb7c5a07139c710ddf063b58ed6bc15d1f58529dfaa0d8f1935cb513fe27ad5e95af0ca7383922f5642d1197cf74183ba2463a3fa81637add5d8376691 SHA512 3dffc21aae59ebc8c7b3ef3df588f958b4a42a2025dc6a82613e9bb1b324f8c999d01b8d98ed48794b3ea8fd5c3221df489a88f8c54c154a69be9908beda85b5
DIST ibus-typing-booster-2.8.3.tar.gz 8184044 BLAKE2B 06b7bc3c39f8c135d5e6d2c90ceaa2df8c38041cb4cc7d583cc335bb3bbdbf4915a6bcb0fff80bbaae797e8bda74bed26077ab4739a8f9584ecfaade833eefbb SHA512 18cee36b5f5c3d6da1cb455e785317c0e2b9826e49e3b2655f4f7a3fce4bdd279ff24614083559996031876702879530799a709e196dc5d68345f0d942972dff
+DIST ibus-typing-booster-2.9.0.tar.gz 8191076 BLAKE2B 4b0e53679b907fce56361c60aed2d50f0ac3bef422f9c56b4b5ca8733734c0341f90dfbcf2a9db747a801d999a49198de2b091badf8efe141d22fddb9b35ec6c SHA512 33e0c53e3f16e312eee7db2395d0a5506150e60a47882a7531c9d082e0ca405aabd922b4774a507399d31f38feed78fb87a09efc5550f08dd3794703f1fab235
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild
new file mode 100644
index 000000000000..ed1abe745449
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}