summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-10-27 18:12:56 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-10-27 18:14:27 +0900
commit95a6318370e63b72b9d8d6fa72043774a3b00596 (patch)
tree5d348472121b3c2790fd562081bce521131e583f /app-i18n/ibus-typing-booster
parentdev-ruby/whole_history_rating: use ls instead of git ls-files (diff)
downloadgentoo-95a6318370e63b72b9d8d6fa72043774a3b00596.tar.gz
gentoo-95a6318370e63b72b9d8d6fa72043774a3b00596.tar.bz2
gentoo-95a6318370e63b72b9d8d6fa72043774a3b00596.zip
app-i18n/ibus-typing-booster: new upstream release
Closes: https://bugs.gentoo.org/694464 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.7.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 4e6e38972470..945dfe3c2736 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.5.3.tar.gz 6463060 BLAKE2B c1053f2e9536ee1dd1c243702150e7f0d1dce1651a196a705395890d3d6274a369c718c66c62d96bd317862d831da8195e70bddcde53fef27c1531e5525193ae SHA512 6d7f033919223522c9b0fcef5af4d8368f126c2da1acbbb0403c0575cdedaddd1de7d5cbcdf15dda63b05a871f35708586628195c3da4cfd86ca12bfde452672
DIST ibus-typing-booster-2.6.0.tar.gz 6863400 BLAKE2B e399ebaa19a2949882de41cb3b11dfc161a0ddb300e23daf216857dea9bb4b3d31db6dcd02846214b8ac677df92672a342c7c9e992ab791f97bdf8abc514ba4a SHA512 7e916eaba5d3f14bde383acedd5ce9cd74e72328f25a84936055ee9183b4aeff79d5297fffdd27713491f23a949377cafc39bc52efa0f7d5995672176cb808c8
+DIST ibus-typing-booster-2.7.0.tar.gz 7364094 BLAKE2B 60a45121b398032b2581d1f3e5929e74e69ee22bf0807b069529afb30797daacece47e83b0696397e6b9c3f6adc28012c7f2b7102387e03eb360383946e836b2 SHA512 a11d2cad660dc813022eda89bb690e3fe7cd517ad6a3cbc7f31879afb60c5d1628f25beb423f922b26d7dd92c685471c767084cdd3a35aff1e2314a21cd757c1
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.7.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.7.0.ebuild
new file mode 100644
index 000000000000..b026527d36a3
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"