summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-03-02 22:01:29 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-03-02 22:01:29 +0900
commitc1f8aceba92191a7f6326040f06405b60b66e7b3 (patch)
treecda0c47715d8ba69c4e4449e5a7db5510aa422b5 /app-i18n/ibus-typing-booster
parentwww-servers/h2o: fix build with >=dev-libs/libressl-2.7 (diff)
downloadgentoo-c1f8aceba92191a7f6326040f06405b60b66e7b3.tar.gz
gentoo-c1f8aceba92191a7f6326040f06405b60b66e7b3.tar.bz2
gentoo-c1f8aceba92191a7f6326040f06405b60b66e7b3.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 41a56def5d52..b688bd164365 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.5.1.tar.gz 6232907 BLAKE2B 60fa4b287eb61b509e938d7570dcd9db3160ed66dde56ebae17cb3f46c1862d626dede4dca330b292585fb7db86ee97ed5cd020431a300eaf864a35cad76b99a SHA512 69ba68d6da262762df6db3c98ff947d189463eea761aed42b62cc02dee4c6f7badd533300203a4c6d81e53874ff80da2829a3c82a7acdddf4b1cd99556b0eda1
DIST ibus-typing-booster-2.5.3.tar.gz 6463060 BLAKE2B c1053f2e9536ee1dd1c243702150e7f0d1dce1651a196a705395890d3d6274a369c718c66c62d96bd317862d831da8195e70bddcde53fef27c1531e5525193ae SHA512 6d7f033919223522c9b0fcef5af4d8368f126c2da1acbbb0403c0575cdedaddd1de7d5cbcdf15dda63b05a871f35708586628195c3da4cfd86ca12bfde452672
+DIST ibus-typing-booster-2.6.0.tar.gz 6863400 BLAKE2B e399ebaa19a2949882de41cb3b11dfc161a0ddb300e23daf216857dea9bb4b3d31db6dcd02846214b8ac677df92672a342c7c9e992ab791f97bdf8abc514ba4a SHA512 7e916eaba5d3f14bde383acedd5ce9cd74e72328f25a84936055ee9183b4aeff79d5297fffdd27713491f23a949377cafc39bc52efa0f7d5995672176cb808c8
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild
new file mode 100644
index 000000000000..2b94c3fcc8c1
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"