summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-06-02 10:44:14 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-02 18:37:15 -0400
commit8367e236ce75b1980cfccaf47e83d2d4e8b2f557 (patch)
treecf92b98641d875654d0a4e07bb36494ef7156ffb /app-i18n/kanjipad/kanjipad-2.0.0.ebuild
parentdev-db/oracle-instantclient-sqlplus: drop EAPI=0 ebuilds (diff)
downloadgentoo-8367e236ce75b1980cfccaf47e83d2d4e8b2f557.tar.gz
gentoo-8367e236ce75b1980cfccaf47e83d2d4e8b2f557.tar.bz2
gentoo-8367e236ce75b1980cfccaf47e83d2d4e8b2f557.zip
app-i18n/kanjipad: bump EAPI; drop eutils; use https
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8692
Diffstat (limited to 'app-i18n/kanjipad/kanjipad-2.0.0.ebuild')
-rw-r--r--app-i18n/kanjipad/kanjipad-2.0.0.ebuild36
1 files changed, 20 insertions, 16 deletions
diff --git a/app-i18n/kanjipad/kanjipad-2.0.0.ebuild b/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
index 790545ce7d57..82d47a93e351 100644
--- a/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
+++ b/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Japanese handwriting recognition tool"
-HOMEPAGE="http://fishsoup.net/software/kanjipad/"
-SRC_URI="http://fishsoup.net/software/kanjipad/${P}.tar.gz"
+HOMEPAGE="https://fishsoup.net/software/kanjipad/"
+SRC_URI="https://fishsoup.net/software/kanjipad/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ppc64"
+KEYWORDS="amd64 ppc64 x86"
IUSE=""
RDEPEND="x11-libs/gtk+:2
@@ -19,22 +19,26 @@ RDEPEND="x11-libs/gtk+:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
+DOCS=( ChangeLog README TODO jstroke/README-kanjipad )
+
+PATCHES=(
+ "${FILESDIR}/${P}-cflags.patch"
+ "${FILESDIR}/${P}-underlinking.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-cflags.patch \
- "${FILESDIR}"/${P}-underlinking.patch
+ default
+ perl -i -pe "s|PREFIX=/usr/local|PREFIX=/usr|;
+ s|-DG.*DISABLE_DEPRECATED||g" Makefile || die "Fixing Makefile failed"
}
-src_compile() {
+src_configure() {
tc-export CC
- perl -i -pe "s|PREFIX=/usr/local|PREFIX=/usr|;
- s|-DG.*DISABLE_DEPRECATED||g" Makefile || die
-
- emake || die
}
src_install() {
- dobin kanjipad kpengine || die
+ dobin kanjipad kpengine
insinto /usr/share/kanjipad
- doins jdata.dat || die
- dodoc ChangeLog README TODO jstroke/README-kanjipad
+ doins jdata.dat
+ einstalldocs
}