summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/kcc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/kcc')
-rw-r--r--app-i18n/kcc/Manifest1
-rw-r--r--app-i18n/kcc/files/kcc-exit.diff10
-rw-r--r--app-i18n/kcc/files/kcc-gcc3-gentoo.diff47
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild35
-rw-r--r--app-i18n/kcc/metadata.xml5
5 files changed, 98 insertions, 0 deletions
diff --git a/app-i18n/kcc/Manifest b/app-i18n/kcc/Manifest
new file mode 100644
index 000000000000..12d1e3d80c0b
--- /dev/null
+++ b/app-i18n/kcc/Manifest
@@ -0,0 +1 @@
+DIST kcc.tar.gz 18869 SHA256 4f77ab0bcd7b377bca887973eb364ba5b2f9a0c057fb7e0f9b998f020f57d231 SHA512 2ec1645bb7edbe49c6845cd6e6794568bd48efec367d2d9628ddb8a72d2b5edd590be101f4d9c8856764ae85c9aad7b0adf69601b78fddffdc23235b96f65145 WHIRLPOOL b957057124acaacb61141d26b509ed8b73443b68d8a5f3fb4e498807dcc6f3aa88e120b1467adede86990f85a07776459e7bd0f1224ec8f79b2c1595074ef978
diff --git a/app-i18n/kcc/files/kcc-exit.diff b/app-i18n/kcc/files/kcc-exit.diff
new file mode 100644
index 000000000000..478977a88256
--- /dev/null
+++ b/app-i18n/kcc/files/kcc-exit.diff
@@ -0,0 +1,10 @@
+--- a/kcc.c
++++ b/kcc.c
+@@ -27,6 +27,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/app-i18n/kcc/files/kcc-gcc3-gentoo.diff b/app-i18n/kcc/files/kcc-gcc3-gentoo.diff
new file mode 100644
index 000000000000..88f08e20161d
--- /dev/null
+++ b/app-i18n/kcc/files/kcc-gcc3-gentoo.diff
@@ -0,0 +1,47 @@
+--- a/kcc.c
++++ b/kcc.c
+@@ -134,7 +134,11 @@
+ extern unsigned short hiragana[];
+ unsigned short *kanatbl = katakana;
+
++#ifdef __STDC__
++void error(char *format, ...);
++#else
+ void error();
++#endif
+
+ /**********************************************************************
+ * *
+@@ -364,14 +368,30 @@
+ NAME
+ error - print formatted error message on stderr and die
+ ---------------------------------------------------------------------*/
++#ifdef __STDC__
++#include <stdarg.h>
++#else
+ #include <varargs.h>
++#endif
+
+-void error(va_alist)
+- va_dcl
++void
++#ifdef __STDC__
++error(char *format, ...)
++#else
++error(va_alist) va_dcl
++#endif
+ {
+ va_list args;
+
++#ifdef __STDC__
++ va_start(args, format);
++#else
++ char *format;
++
+ va_start(args);
++ /* extract the fixed argument */
++ format = va_arg(args, char *);
++#endif
+ fprintf(stderr, "%s: ", progname);
+ vfprintf(stderr, va_arg(args, char *), args);
+ putc('\n', stderr);
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
new file mode 100644
index 000000000000..850711cc64d1
--- /dev/null
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Kanji code converter"
+HOMEPAGE="http://www2s.biglobe.ne.jp/~Nori/ruby/"
+SRC_URI="ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/distfiles/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-gcc3-gentoo.diff"
+ epatch "${FILESDIR}/${PN}-exit.diff"
+ sed -i "s:\(-o kcc\):\$(LDFLAGS) \1:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin kcc
+ dodoc README
+ cp -f kcc.jman kcc.1 || die
+ doman -i18n=ja kcc.1
+}
diff --git a/app-i18n/kcc/metadata.xml b/app-i18n/kcc/metadata.xml
new file mode 100644
index 000000000000..cb36a2fd8c76
--- /dev/null
+++ b/app-i18n/kcc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+</pkgmetadata>