summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/kinput2/kinput2-3.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/kinput2/kinput2-3.1-r2.ebuild')
-rw-r--r--app-i18n/kinput2/kinput2-3.1-r2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-i18n/kinput2/kinput2-3.1-r2.ebuild b/app-i18n/kinput2/kinput2-3.1-r2.ebuild
new file mode 100644
index 000000000000..86aae3e92753
--- /dev/null
+++ b/app-i18n/kinput2/kinput2-3.1-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit eutils
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="A Japanese input server which supports the XIM protocol"
+HOMEPAGE="http://www.nec.co.jp/canna/"
+SRC_URI="ftp://ftp.sra.co.jp/pub/x11/${PN}/${MY_P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE="freewnn"
+
+RDEPEND="freewnn? ( >=app-i18n/freewnn-1.1.1_alpha19 )
+ !freewnn? ( >=app-i18n/canna-3.5_beta2-r1 )
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXt"
+
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake
+ app-text/rman"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-r1-gentoo.diff"
+
+ if use freewnn; then
+ sed -i -e '/\/\* #define UseWnn/s:^:#define UseWnn\n:' Kinput2.conf || die
+ else
+ sed -i -e '/\/\* #define UseCanna/s:^:#define UseCanna\n:' Kinput2.conf || die
+ fi
+}
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ XAPPLOADDIR="${EPREFIX}/usr/share/X11/app-defaults/" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ emake XAPPLOADDIR="/usr/share/X11/app-defaults/" DESTDIR="${D}" install || die
+ rm -rf "${ED}/usr/lib/X11" || die
+
+ local server
+ if use freewnn; then
+ server="wnn"
+ else
+ server="canna"
+ fi
+
+ insinto /etc/X11/xinit/xinput.d
+ sed \
+ -e "s:@EPREFIX@:${EPREFIX}:g" \
+ -e "s:@SERVER@:${server}:g" \
+ "${FILESDIR}/xinput-kinput2" > "${T}/kinput2.conf" || die
+ doins "${T}/kinput2.conf" || die
+
+ dodoc README NEWS doc/* || die
+ newman cmd/${PN}.man ${PN}.1 || die
+}