summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 00:15:09 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:30:32 -0400
commit94d9b50bc71ddfb8a2f34eb01cd4d2763a901264 (patch)
treebe511cea0f5ca68a442bf7c859c682a508b15e01 /app-i18n/kinput2
parentdev-java/gradle-bin: drop 7.5 (diff)
downloadgentoo-94d9b50bc71ddfb8a2f34eb01cd4d2763a901264.tar.gz
gentoo-94d9b50bc71ddfb8a2f34eb01cd4d2763a901264.tar.bz2
gentoo-94d9b50bc71ddfb8a2f34eb01cd4d2763a901264.zip
app-i18n/kinput2: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Closes: https://bugs.gentoo.org/829063 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-i18n/kinput2')
-rw-r--r--app-i18n/kinput2/kinput2-3.1-r3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-i18n/kinput2/kinput2-3.1-r3.ebuild b/app-i18n/kinput2/kinput2-3.1-r3.ebuild
index 87035d98354a..2420751e6974 100644
--- a/app-i18n/kinput2/kinput2-3.1-r3.ebuild
+++ b/app-i18n/kinput2/kinput2-3.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -26,7 +26,9 @@ RDEPEND="app-i18n/freewnn
x11-libs/libXpm
x11-libs/libXt"
DEPEND="${RDEPEND}"
-BDEPEND="x11-misc/gccmakedep
+BDEPEND="
+ sys-devel/gcc
+ x11-misc/gccmakedep
>=x11-misc/imake-1.0.8-r1"
S="${WORKDIR}/${MY_P}"
@@ -45,7 +47,8 @@ src_prepare() {
}
src_configure() {
- CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}
src_compile() {