summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2021-11-18 09:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2021-11-18 17:22:10 -0500
commitf684c5b95b944d2e820bd300da5e68f3832890ea (patch)
treec5094a70930a2a205a68406a281817bc252576d0 /app-i18n/librime-lua
parentapp-i18n/librime-lua: Delete support for Lua 5.1 and 5.2. (diff)
downloadgentoo-f684c5b95b944d2e820bd300da5e68f3832890ea.tar.gz
gentoo-f684c5b95b944d2e820bd300da5e68f3832890ea.tar.bz2
gentoo-f684c5b95b944d2e820bd300da5e68f3832890ea.zip
app-i18n/librime-lua: Version bump (20211030072627).
Closes: https://bugs.gentoo.org/787593 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/librime-lua')
-rw-r--r--app-i18n/librime-lua/Manifest1
-rw-r--r--app-i18n/librime-lua/librime-lua-20211030072627.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-i18n/librime-lua/Manifest b/app-i18n/librime-lua/Manifest
index 63cef86cfde2..8229a6191846 100644
--- a/app-i18n/librime-lua/Manifest
+++ b/app-i18n/librime-lua/Manifest
@@ -1 +1,2 @@
DIST librime-lua-20201011103348.tar.gz 21600 BLAKE2B f7046d1eb23391ca70543aa64c52092081cef51a69ac3a282f2f1392eaf760515186f063e9d469c5c41ac9f495ace814ab741a0821d1a635b9ad1f4faa7a3912 SHA512 2a3d3b49d53066fe96dd008e8064718082225e6bf185574a25b8e98175d9936abcfa1fdc56e48f9c72a2deb46f8157d6132fd119ff8e0a3d52fbe9e2ea21386c
+DIST librime-lua-20211030072627.tar.gz 27894 BLAKE2B a527e865a9945aa7d56cce3905bc80156b60ebf6323828ca40999cb73ebe8d8f66ddf6b0a1d6d5904f2bc754b5f8fe6ac1f5ecdc56351c2222a21429a0c2b701 SHA512 b15f85b0a18e5e05fa691a84aef7cf3689b4a5271a1d5b6f78ea42488f6dbe4dfc56a91fa547ca3636269b9c898d646d24d3a160096ace9927901f9fdba06e9c
diff --git a/app-i18n/librime-lua/librime-lua-20211030072627.ebuild b/app-i18n/librime-lua/librime-lua-20211030072627.ebuild
new file mode 100644
index 000000000000..74d5ffac79a3
--- /dev/null
+++ b/app-i18n/librime-lua/librime-lua-20211030072627.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+LUA_COMPAT=(lua{5-3,5-4})
+
+inherit cmake lua-single
+
+if [[ "${PV}" == "99999999999999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hchunhui/librime-lua"
+else
+ LIBRIME_LUA_GIT_REVISION="67ef681a9fd03262c49cc7f850cc92fc791b1e85"
+fi
+
+DESCRIPTION="Lua module for RIME"
+HOMEPAGE="https://github.com/hchunhui/librime-lua"
+if [[ "${PV}" == "99999999999999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/hchunhui/${PN}/archive/${LIBRIME_LUA_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+BDEPEND=""
+RDEPEND=">=app-i18n/librime-1.6:0=
+ ${LUA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/boost:0"
+
+if [[ "${PV}" != "99999999999999" ]]; then
+ S="${WORKDIR}/${PN}-${LIBRIME_LUA_GIT_REVISION}"
+fi
+
+src_prepare() {
+ sed \
+ -e "1icmake_minimum_required(VERSION 3.0)\nproject(${PN})\n" \
+ -e "s/ PARENT_SCOPE//" \
+ -e "\$a\\\n" \
+ -e "\$aadd_library(\${plugin_modules} MODULE \${plugin_objs})" \
+ -e "\$aset_target_properties(\${plugin_modules} PROPERTIES PREFIX \"\")" \
+ -e "\$atarget_link_libraries(\${plugin_modules} rime \${plugin_deps})" \
+ -e "\$ainstall(TARGETS \${plugin_modules} DESTINATION $(get_libdir)/rime-plugins)" \
+ -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}