summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-17 22:13:22 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-17 22:13:22 +0100
commit55d4c2a2e327ca41ac88c5397fb7a294095cbeca (patch)
tree9f90cb4ddb0529fcf2f2be19a74c71a36c48bb4b /app-i18n/man-pages-de/man-pages-de-1.11.ebuild
parenteclass/eutils.eclass: epatch_user: Strip subslot when taking patches from /e... (diff)
downloadgentoo-55d4c2a2e327ca41ac88c5397fb7a294095cbeca.tar.gz
gentoo-55d4c2a2e327ca41ac88c5397fb7a294095cbeca.tar.bz2
gentoo-55d4c2a2e327ca41ac88c5397fb7a294095cbeca.zip
app-i18n/man-pages-de: Version bump. Proxied commit for Markus Oehme
Gentoo-Bug: 574988 Package-Manager: portage-2.2.27
Diffstat (limited to 'app-i18n/man-pages-de/man-pages-de-1.11.ebuild')
-rw-r--r--app-i18n/man-pages-de/man-pages-de-1.11.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-i18n/man-pages-de/man-pages-de-1.11.ebuild b/app-i18n/man-pages-de/man-pages-de-1.11.ebuild
new file mode 100644
index 000000000000..4f6cf7deefe3
--- /dev/null
+++ b/app-i18n/man-pages-de/man-pages-de-1.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+MY_P="${PN/-/}-${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="http://alioth.debian.org/projects/manpages-de/"
+SRC_URI="http://manpages-de.alioth.debian.org/downloads/${MY_P}.tar.xz"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+DEPEND="${RDEPEND}
+ app-text/po4a"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3-bzip2.patch
+
+ # Use the same compression as every other manpage
+ local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+ if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then
+ PORTAGE_COMPRESS_LOCAL="#"
+ fi
+ if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2|gzip) local PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+ ;;
+ esac
+ fi
+ sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\
+ po/man{1,2,3,4,5,6,7,8}/Makefile.in po/common.mk || die
+ eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake mandir="${ED}"/usr/share/man install
+ dodoc CHANGES README
+}