summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2018-10-10 02:56:23 +0900
committerNaohiro Aota <naota@gentoo.org>2018-10-10 02:57:31 +0900
commit50be00f6ee1ce7eaa585389586a5d838e65e647b (patch)
tree2ed4aa43b6ffad6d0a821075ddc88574e2c51269 /app-i18n/opencc/opencc-9999.ebuild
parentdev-embedded/arduino-builder: version bump to 1.4.1 (diff)
downloadgentoo-50be00f6ee1ce7eaa585389586a5d838e65e647b.tar.gz
gentoo-50be00f6ee1ce7eaa585389586a5d838e65e647b.tar.bz2
gentoo-50be00f6ee1ce7eaa585389586a5d838e65e647b.zip
app-i18n/opencc: add patch to avoid conflicting copy
copy command is only necessary in VS build, and it's causing conflict on parallel build. Dropping the command is safe on Linux. Closes: https://bugs.gentoo.org/666904 Signed-off-by: Naohiro Aota <naota@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-i18n/opencc/opencc-9999.ebuild')
-rw-r--r--app-i18n/opencc/opencc-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-i18n/opencc/opencc-9999.ebuild b/app-i18n/opencc/opencc-9999.ebuild
index 9ec1cbd5d8b7..857d6dd70b8e 100644
--- a/app-i18n/opencc/opencc-9999.ebuild
+++ b/app-i18n/opencc/opencc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -26,7 +26,10 @@ IUSE="doc test"
DEPEND="doc? ( app-doc/doxygen )"
DOCS="AUTHORS *.md"
-PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-test.patch
+ "${FILESDIR}"/${PN}-stop-copy.patch
+)
src_prepare() {
sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt