summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-03-12 19:45:01 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-12 19:45:01 +0100
commitf61de7dd714cda621bc18fa93e78c89237c94223 (patch)
treea8ed1af8b81bbf4ed5c9054290514a5eb8ef46b9 /app-i18n/opencc
parentapp-i18n/mozc: remove unused patches (diff)
downloadgentoo-f61de7dd714cda621bc18fa93e78c89237c94223.tar.gz
gentoo-f61de7dd714cda621bc18fa93e78c89237c94223.tar.bz2
gentoo-f61de7dd714cda621bc18fa93e78c89237c94223.zip
app-i18n/opencc: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/24516 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-i18n/opencc')
-rw-r--r--app-i18n/opencc/files/opencc-1.1.0-parallel_build.patch40
-rw-r--r--app-i18n/opencc/files/opencc-1.1.1-system_libraries.patch94
2 files changed, 0 insertions, 134 deletions
diff --git a/app-i18n/opencc/files/opencc-1.1.0-parallel_build.patch b/app-i18n/opencc/files/opencc-1.1.0-parallel_build.patch
deleted file mode 100644
index 3163aa0a16e3..000000000000
--- a/app-i18n/opencc/files/opencc-1.1.0-parallel_build.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-https://github.com/BYVoid/OpenCC/issues/322
-
---- /data/CMakeLists.txt
-+++ /data/CMakeLists.txt
-@@ -116,6 +116,19 @@
- )
- endforeach(DICT)
-
-+add_custom_target(
-+ copy_libopencc_to_dir_of_opencc_dict
-+ COMMENT
-+ "Copying libopencc to directory of opencc_dict"
-+ COMMAND
-+ ${CMAKE_COMMAND} -E copy "$<TARGET_FILE:libopencc>" "$<TARGET_FILE_DIR:${OPENCC_DICT_BIN}>"
-+)
-+if (WIN32)
-+ set(DICT_WIN32_DEPENDS copy_libopencc_to_dir_of_opencc_dict)
-+else()
-+ set(DICT_WIN32_DEPENDS)
-+endif()
-+
- foreach(DICT ${DICTS})
- add_custom_command(
- OUTPUT
-@@ -123,14 +136,13 @@
- COMMENT
- "Building ${DICT}.ocd2"
- COMMAND
-- ${CMAKE_COMMAND} -E copy "$<TARGET_FILE:libopencc>" "$<TARGET_FILE_DIR:${OPENCC_DICT_BIN}>"
-- COMMAND
- ${OPENCC_DICT_BIN}
- --input ${DICT_${DICT}_INPUT}
- --output ${DICT}.ocd2
- --from text
- --to ocd2
- DEPENDS
-+ ${DICT_WIN32_DEPENDS}
- ${OPENCC_DICT_BIN}
- ${DICT_${DICT}_INPUT}
- )
diff --git a/app-i18n/opencc/files/opencc-1.1.1-system_libraries.patch b/app-i18n/opencc/files/opencc-1.1.1-system_libraries.patch
deleted file mode 100644
index ee0527f22356..000000000000
--- a/app-i18n/opencc/files/opencc-1.1.1-system_libraries.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-https://github.com/BYVoid/OpenCC/issues/547
-
---- /CMakeLists.txt
-+++ /CMakeLists.txt
-@@ -28,7 +28,12 @@
- option(ENABLE_GTEST "Build all tests." OFF)
- option(ENABLE_BENCHMARK "Build benchmark tests." OFF)
- option(ENABLE_DARTS "Build DartsDict (ocd format)." ON)
--option(BUILD_BUNDLED_LIBMARISA "" ON)
-+option(USE_SYSTEM_DARTS "Use system version of Darts" OFF)
-+option(USE_SYSTEM_GOOGLE_BENCHMARK "Use system version of Google Benchmark" OFF)
-+option(USE_SYSTEM_GTEST "Use system version of GoogleTest" OFF)
-+option(USE_SYSTEM_MARISA "Use system version of Marisa" OFF)
-+option(USE_SYSTEM_RAPIDJSON "Use system version of RapidJSON" OFF)
-+option(USE_SYSTEM_TCLAP "Use system version of TCLAP" OFF)
-
- ######## Package information
- set (PACKAGE_URL https://github.com/BYVoid/Opencc)
-@@ -172,7 +177,7 @@
-
- ######## Dependencies
-
--if(BUILD_BUNDLED_LIBMARISA)
-+if(NOT USE_SYSTEM_MARISA)
- message(STATUS "Use bundled marisa library.")
- add_subdirectory(deps/marisa-0.2.5)
- else()
-@@ -194,12 +199,16 @@
- ######## Testing
-
- if (ENABLE_GTEST)
-- add_subdirectory(deps/gtest-1.11.0)
-+ if(NOT USE_SYSTEM_GTEST)
-+ add_subdirectory(deps/gtest-1.11.0)
-+ endif()
- enable_testing()
- endif()
-
- if (ENABLE_BENCHMARK)
- set(BENCHMARK_ENABLE_TESTING OFF)
-- add_subdirectory(deps/google-benchmark)
-+ if(NOT USE_SYSTEM_GOOGLE_BENCHMARK)
-+ add_subdirectory(deps/google-benchmark)
-+ endif()
- enable_testing()
- endif()
---- /src/CMakeLists.txt
-+++ /src/CMakeLists.txt
-@@ -1,7 +1,13 @@
- include (GenerateExportHeader)
--include_directories(../deps/marisa-0.2.5/include)
--include_directories(../deps/rapidjson-1.1.0)
--include_directories(../deps/tclap-1.2.2)
-+if(NOT USE_SYSTEM_MARISA)
-+ include_directories(../deps/marisa-0.2.5/include)
-+endif()
-+if(NOT USE_SYSTEM_RAPIDJSON)
-+ include_directories(../deps/rapidjson-1.1.0)
-+endif()
-+if(NOT USE_SYSTEM_TCLAP)
-+ include_directories(../deps/tclap-1.2.2)
-+endif()
-
- # Library
-
-@@ -72,7 +78,9 @@
- )
-
- if (ENABLE_DARTS)
-- include_directories(../deps/darts-clone)
-+ if(NOT USE_SYSTEM_DARTS)
-+ include_directories(../deps/darts-clone)
-+ endif()
- set(
- LIBOPENCC_HEADERS
- ${LIBOPENCC_HEADERS}
---- /test/CMakeLists.txt
-+++ /test/CMakeLists.txt
-@@ -1,4 +1,3 @@
--include_directories(../deps/libdarts/src)
- include_directories(../src)
-
- set(CONFIG_TEST
-@@ -27,7 +26,9 @@
- )
- endif()
-
-- include_directories(../deps/gtest-1.7.0/include)
-+ if(NOT USE_SYSTEM_GTEST)
-+ include_directories(../deps/gtest-1.7.0/include)
-+ endif()
- set(UNITTESTS
- CommandLineConvertTest
- )