summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-05-27 18:00:33 +0800
committerYixun Lan <dlan@gentoo.org>2016-05-27 18:20:30 +0800
commitc128d1b74954557d0e6d9df085b0a822450bb6e3 (patch)
tree19b98a815f3b1b2928916b3589f0ae8667ea7bd2 /app-i18n/pyzy/pyzy-0.1.0-r2.ebuild
parentapp-i18n/fcitx-libpinyin: version bump 0.3.3 (diff)
downloadgentoo-c128d1b74954557d0e6d9df085b0a822450bb6e3.tar.gz
gentoo-c128d1b74954557d0e6d9df085b0a822450bb6e3.tar.bz2
gentoo-c128d1b74954557d0e6d9df085b0a822450bb6e3.zip
app-i18n/pyzy: support opencc-1.0.4
Gentoo-Bug: 580782 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-i18n/pyzy/pyzy-0.1.0-r2.ebuild')
-rw-r--r--app-i18n/pyzy/pyzy-0.1.0-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-i18n/pyzy/pyzy-0.1.0-r2.ebuild b/app-i18n/pyzy/pyzy-0.1.0-r2.ebuild
new file mode 100644
index 000000000000..22cbf96ae2f2
--- /dev/null
+++ b/app-i18n/pyzy/pyzy-0.1.0-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-any-r1 autotools
+
+PY_DATABASE=${PN}-database-1.0.0
+DESCRIPTION="The Chinese PinYin and Bopomofo conversion library"
+HOMEPAGE="https://github.com/pyzy/pyzy"
+SRC_URI="https://pyzy.googlecode.com/files/${P}.tar.gz
+ https://pyzy.googlecode.com/files/${PY_DATABASE}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost doc opencc test"
+
+RDEPEND="dev-libs/glib:2
+ dev-db/sqlite:3
+ sys-apps/util-linux
+ boost? ( dev-libs/boost )
+ opencc? ( app-i18n/opencc )"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )"
+
+# Currently it fails to build test code
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-dont-download-dictionary-file.patch
+ epatch "${FILESDIR}"/${PN}-support-opencc-1.0.0.patch
+
+ mv ../db ./data/db/open-phrase/ || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-db-open-phrase \
+ --enable-db-android \
+ $(use_enable boost) \
+ $(use_enable opencc) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ use doc && dohtml -r docs/html/*
+}