summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-31 14:06:25 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-31 14:07:11 +0100
commit118bb1c0252c90d68283e5ada7324fe096006478 (patch)
treeb08d9e435a541106ccb8abbd4cb43cf73f83a7d2 /app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
parentdev-libs/rlog: Port to EAPI 6 (diff)
downloadgentoo-118bb1c0252c90d68283e5ada7324fe096006478.tar.gz
gentoo-118bb1c0252c90d68283e5ada7324fe096006478.tar.bz2
gentoo-118bb1c0252c90d68283e5ada7324fe096006478.zip
app-i18n/scim-wijesekera: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild')
-rw-r--r--app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
index 69f362e5b6ec..28914bc279f6 100644
--- a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
+++ b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Wijesekara keyboard for Sinhala input using scim"
HOMEPAGE="http://sinhala.sourceforge.net/"
@@ -18,13 +18,20 @@ RDEPEND=">=app-i18n/scim-0.99.8[-gtk3]"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
+
src_prepare() {
- epatch "${FILESDIR}/${P}-gcc43.patch"
+ default
eautoreconf
}
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
- dodoc AUTHORS ChangeLog NEWS README
+ # plugin module, no point in .la files
+ find "${D}" -name '*.la' -delete || die
}