summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/skk-jisyo/skk-jisyo-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/skk-jisyo/skk-jisyo-9999.ebuild')
-rw-r--r--app-i18n/skk-jisyo/skk-jisyo-9999.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-i18n/skk-jisyo/skk-jisyo-9999.ebuild b/app-i18n/skk-jisyo/skk-jisyo-9999.ebuild
new file mode 100644
index 000000000000..43b6f4d8a2ab
--- /dev/null
+++ b/app-i18n/skk-jisyo/skk-jisyo-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+ECVS_SERVER="openlab.jp:/circus/cvsroot"
+ECVS_USER="guest"
+ECVS_PASS="guest"
+ECVS_MODULE="skk/dic"
+inherit cvs
+
+DESCRIPTION="Jisyo (dictionary) files for the SKK Japanese-input software"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/dic.html"
+#SRC_URI="mirror://gentoo/${P}.tar.bz2"
+SRC_URI=""
+
+LICENSE="GPL-2 public-domain freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cdb"
+
+COMMON_DEPEND="cdb? ( dev-db/cdb )"
+DEPEND="${COMMON_DEPEND}
+ sys-apps/gawk"
+RDEPEND="${COMMON_DEPEND}
+ !app-i18n/skk-jisyo-extra
+ !app-i18n/skk-jisyo-cdb"
+
+S="${WORKDIR}/${ECVS_MODULE}"
+
+src_unpack() {
+ cvs_src_unpack
+
+ cd "${S}"
+ rm SKK-JISYO.wrong.annotated SKK-JISYO.china_taiwan.header
+ rm SKK-JISYO.noregist SKK-JISYO.not_wrong SKK-JISYO.hukugougo
+ rm SKK-JISYO.notes SKK-JISYO.requested SKK-JISYO.pubdic+
+}
+
+src_compile() {
+ # bug 184457
+ unset LANG LC_ALL LC_CTYPE
+
+ for f in SKK-JISYO.* zipcode/SKK-JISYO.* ; do
+ mv ${f} ${f}.annotated
+ gawk -f "${FILESDIR}"/unannotation.awk ${f}.annotated > $(basename ${f}) || die
+ if use cdb ; then
+ gawk '
+ /^[^;]/ {
+ s = substr($0, index($0, " ") + 1)
+ print "+" length($1) "," length(s) ":" $1 "->" s
+ }
+ END {
+ print ""
+ }
+ ' $(basename ${f}) | cdbmake $(basename ${f}).cdb "${T}"/$(basename ${f}) || die
+ fi
+ rm ${f}.annotated
+ done
+}
+
+src_install() {
+ # install dictionaries
+ insinto /usr/share/skk
+ doins SKK-JISYO.* || die
+
+ dodoc ChangeLog* READMEs/committers.txt edict_doc.txt
+}