summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild')
-rw-r--r--app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild b/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild
new file mode 100644
index 000000000000..a9684f78cab5
--- /dev/null
+++ b/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Open-source Japanese dictionary and kanji lookup tool"
+HOMEPAGE="http://www.tagaini.net/"
+SRC_URI="https://github.com/Gnurou/tagainijisho/releases/download/${PV}/${P}.tar.gz"
+LICENSE="GPL-3+ public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+pkg_linguas=( ar cs de es fi_FI fr it nb nl pt ru sv th tr vi )
+IUSE+=" ${pkg_linguas[@]/#/linguas_}"
+
+src_configure() {
+ # GUI linguas
+ # en is not optional, and build fails if none other then en is set, so adding ja as non-optional too
+ # linguas undeclared in IUSE will trigger an error, which is a handy check
+ for lingua in $(ls -1 i18n/*.ts | sed -e 's/.*tagainijisho_\(.*\)\.ts/\1/' | grep -v en | grep -v ja); do
+ if ! use linguas_${lingua}; then
+ rm i18n/tagainijisho_${lingua}.ts || die
+ fi
+ done
+
+ # Dictionary linguas
+ # en is not optional here either, but nothing special needs to be done
+ # here too, linguas undeclared in IUSE will trigger an error
+ local cmake_linguas
+ for lingua in $(sed -e 's/;/ /g' -ne '/set(DICT_LANG ".*")/s/.*"\(.*\)".*/\1/p' CMakeLists.txt); do
+ if use linguas_${lingua}; then
+ cmake_linguas+=";${lingua}"
+ fi
+ done
+ mycmakeargs=( -DDICT_LANG="${cmake_linguas};" )
+
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}