summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerenc Erki <erkiferenc@gmail.com>2018-03-26 06:47:38 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-04-09 00:42:04 +0200
commit408d48af944b785f2fa98f219cb3635d3b99bdf9 (patch)
tree359b809f81f8844eb6dffdef6c500e386d28e4e3 /app-i18n/translate-shell/translate-shell-0.9.6.7.ebuild
parentx11-plugins/gkrellm-imonc-0.2-r1: fix HOMEPAGE. (diff)
downloadgentoo-408d48af944b785f2fa98f219cb3635d3b99bdf9.tar.gz
gentoo-408d48af944b785f2fa98f219cb3635d3b99bdf9.tar.bz2
gentoo-408d48af944b785f2fa98f219cb3635d3b99bdf9.zip
app-i18n/translate-shell: version bump to 0.9.6.7.
Closes: https://bugs.gentoo.org/652150 Closes: https://github.com/gentoo/gentoo/pull/7767 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-i18n/translate-shell/translate-shell-0.9.6.7.ebuild')
-rw-r--r--app-i18n/translate-shell/translate-shell-0.9.6.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-i18n/translate-shell/translate-shell-0.9.6.7.ebuild b/app-i18n/translate-shell/translate-shell-0.9.6.7.ebuild
new file mode 100644
index 000000000000..6447ab3f65e0
--- /dev/null
+++ b/app-i18n/translate-shell/translate-shell-0.9.6.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Online command-line translator"
+HOMEPAGE="https://www.soimort.org/translate-shell/"
+SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+curl +bidi test tts"
+
+RDEPEND="
+ app-misc/rlwrap
+ >=sys-apps/gawk-4.0.2
+ curl? ( net-misc/curl[ssl] )
+ bidi? ( dev-libs/fribidi )
+ tts? ( || (
+ media-sound/mpg123
+ app-accessibility/espeak
+ media-video/mpv
+ media-video/mplayer
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( app-editors/emacs )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${P}-remove-online-tests.patch"
+)
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}