summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-02-05 10:41:13 +0300
committerMichael Palimaka <kensington@gentoo.org>2017-02-11 22:24:29 +1100
commite770290a48c3590d7da7596f35daf758e101d227 (patch)
treedf2dc99a76c90f58752d5218870e46a452cb7b62 /app-i18n/uchardet/uchardet-9999.ebuild
parentmedia-libs/libsfml: Removed old. (diff)
downloadgentoo-e770290a48c3590d7da7596f35daf758e101d227.tar.gz
gentoo-e770290a48c3590d7da7596f35daf758e101d227.tar.bz2
gentoo-e770290a48c3590d7da7596f35daf758e101d227.zip
app-i18n/uchardet: rename from dev-libs/uchardet
Rationale: - provided functionality better fits app-i18n/ category; - uchardet is similar to existing app-i18n/enca and app-i18n/libguess; - uchardet also provides CLI tool, not only a library. Checklist: 1. `git mv dev-libs/uchardet app-i18n/uchardet` ✓ 2. Add entry to profile/updates/1Q-2017 ✓ 3. Update reverse dependencies ✓ 4. Update entries in profiles/ ✓ 5. Update eclasses that reference the package (there's none) ✓ 6. Update metadata.xml entries that reference the package ✓ 7. Update news items that reference the package (there's none) ✓ Gentoo-Bug: https://bugs.gentoo.org/593176
Diffstat (limited to 'app-i18n/uchardet/uchardet-9999.ebuild')
-rw-r--r--app-i18n/uchardet/uchardet-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/uchardet/uchardet-9999.ebuild b/app-i18n/uchardet/uchardet-9999.ebuild
new file mode 100644
index 000000000000..2d53e33d7c36
--- /dev/null
+++ b/app-i18n/uchardet/uchardet-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="An encoding detector library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
+EGIT_REPO_URI=(
+ https://anongit.freedesktop.org/git/${PN}/${PN}.git
+ git://anongit.freedesktop.org/${PN}/${PN}
+)
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs test"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use test || cmake_comment_add_subdirectory test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}