summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-06-27 00:41:23 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-06-27 00:57:22 +0200
commitb40e8f00320d8c5334d0be9c5f6385c027a371ea (patch)
tree48336b119fdfa0fdba4d07b1b25d0791e67a1b4d /app-i18n/unicode-data/unicode-data-10.0.0.ebuild
parentsys-apps/dog: EAPI 6 bump. (diff)
downloadgentoo-b40e8f00320d8c5334d0be9c5f6385c027a371ea.tar.gz
gentoo-b40e8f00320d8c5334d0be9c5f6385c027a371ea.tar.bz2
gentoo-b40e8f00320d8c5334d0be9c5f6385c027a371ea.zip
app-i18n/unicode-data: Bump to version 10.0.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-i18n/unicode-data/unicode-data-10.0.0.ebuild')
-rw-r--r--app-i18n/unicode-data/unicode-data-10.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/unicode-data/unicode-data-10.0.0.ebuild b/app-i18n/unicode-data/unicode-data-10.0.0.ebuild
new file mode 100644
index 000000000000..eb07fea7ebc3
--- /dev/null
+++ b/app-i18n/unicode-data/unicode-data-10.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Unicode data from unicode.org"
+HOMEPAGE="http://www.unicode.org/ucd/"
+SRC_URI="http://www.unicode.org/Public/zipped/${PV}/UCD.zip -> ${P}-UCD.zip
+ http://www.unicode.org/Public/zipped/${PV}/Unihan.zip -> ${P}-Unihan.zip"
+
+LICENSE="unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # Unihan.zip needs to be installed as a zip for reverse deps
+ # https://bugzilla.gnome.org/show_bug.cgi?id=768210
+ unpack ${P}-UCD.zip
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r "${S}"/*
+ newins "${DISTDIR}"/${P}-Unihan.zip Unihan.zip
+}