summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-01 22:08:35 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-01 22:08:35 +0900
commit5b52787ea119461900b417903685a56cefc390e9 (patch)
tree3d761c0a816e21409834334e0a5f2691b22b0387 /app-i18n/yaskkserv/yaskkserv-1.1.0.ebuild
parentapp-i18n/yaskkserv: amd64/x86 stable (diff)
downloadgentoo-5b52787ea119461900b417903685a56cefc390e9.tar.gz
gentoo-5b52787ea119461900b417903685a56cefc390e9.tar.bz2
gentoo-5b52787ea119461900b417903685a56cefc390e9.zip
app-i18n/yaskkserv: drop old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/yaskkserv/yaskkserv-1.1.0.ebuild')
-rw-r--r--app-i18n/yaskkserv/yaskkserv-1.1.0.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/app-i18n/yaskkserv/yaskkserv-1.1.0.ebuild b/app-i18n/yaskkserv/yaskkserv-1.1.0.ebuild
deleted file mode 100644
index d450001620db..000000000000
--- a/app-i18n/yaskkserv/yaskkserv-1.1.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit toolchain-funcs systemd
-
-DESCRIPTION="Yet Another SKK server"
-HOMEPAGE="http://umiushi.org/~wac/yaskkserv/"
-SRC_URI="http://umiushi.org/~wac/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnutls libressl systemd"
-
-RDEPEND="app-i18n/skk-jisyo
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- systemd? ( virtual/udev[systemd] )"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
-HTML_DOCS=( documentation/. )
-
-src_configure() {
- econf \
- $(use_enable gnutls) \
- $(use_enable systemd) \
- --compiler="${tc-getCXX}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install_all
- einstalldocs
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-
- systemd_dounit examples/${PN}.socket
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-yaskkserv_update() {
- local f
- for f in "${ROOT}"/usr/share/skk/SKK-JISYO.*; do
- case ${f} in
- *.cdb)
- ;;
- *.${PN})
- [[ -f ${f%.*} ]] || rm -f "${f}"
- ;;
- *)
- [[ ${f} -nt ${f}.${PN} ]] && ${PN}_make_dictionary "${f}" "${f}.${PN}"
- ;;
- esac
- done
-}
-
-pkg_postinst() {
- yaskkserv_update
-
- elog "You need to run:"
- elog " emerge --config =${CATEGORY}/${PF}"
- elog "after updating app-i18n/skk-jisyo from next time."
-}
-
-pkg_postrm() {
- rm -f "${ROOT}"/usr/share/skk/SKK-JISYO.*.${PN}
- rmdir "${ROOT}"/usr/share/skk 2>/dev/null
-}
-
-pkg_config() {
- yaskkserv_update
-}