summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-10-03 21:45:03 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-10-03 21:45:03 +0900
commite6049c34ad6f0070f6a6dade1e8cd434a2bfa9cf (patch)
tree166c85d0b0f76bcc707e972a7fcddb6903143429 /app-i18n/yaskkserv/yaskkserv-1.1.1.ebuild
parentdev-ada/gnat-suite-bin: Add gps suite binary and compiler (diff)
downloadgentoo-e6049c34ad6f0070f6a6dade1e8cd434a2bfa9cf.tar.gz
gentoo-e6049c34ad6f0070f6a6dade1e8cd434a2bfa9cf.tar.bz2
gentoo-e6049c34ad6f0070f6a6dade1e8cd434a2bfa9cf.zip
app-i18n/yaskkserv: new upstream release
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/yaskkserv/yaskkserv-1.1.1.ebuild')
-rw-r--r--app-i18n/yaskkserv/yaskkserv-1.1.1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/app-i18n/yaskkserv/yaskkserv-1.1.1.ebuild b/app-i18n/yaskkserv/yaskkserv-1.1.1.ebuild
new file mode 100644
index 000000000000..8faf1afe8655
--- /dev/null
+++ b/app-i18n/yaskkserv/yaskkserv-1.1.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Yet Another SKK server"
+HOMEPAGE="http://umiushi.org/~wac/yaskkserv/"
+SRC_URI="http://umiushi.org/~wac/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls libressl systemd"
+
+RDEPEND="app-i18n/skk-jisyo
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ systemd? ( virtual/udev[systemd] )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
+HTML_DOCS=( documentation/. )
+
+src_configure() {
+ econf \
+ $(use_enable gnutls) \
+ $(use_enable systemd) \
+ --compiler="${tc_getCXX}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install_all
+ einstalldocs
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ systemd_dounit examples/${PN}.socket
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+yaskkserv_update() {
+ local f
+ for f in "${ROOT}"/usr/share/skk/SKK-JISYO.*; do
+ case ${f} in
+ *.cdb)
+ ;;
+ *.${PN})
+ [[ -f ${f%.*} ]] || rm -f "${f}"
+ ;;
+ *)
+ [[ ${f} -nt ${f}.${PN} ]] && ${PN}_make_dictionary "${f}" "${f}.${PN}"
+ ;;
+ esac
+ done
+}
+
+pkg_postinst() {
+ yaskkserv_update
+
+ elog "You need to run:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ elog "after updating app-i18n/skk-jisyo from next time."
+}
+
+pkg_postrm() {
+ rm -f "${ROOT}"/usr/share/skk/SKK-JISYO.*.${PN}
+ rmdir "${ROOT}"/usr/share/skk 2>/dev/null
+}
+
+pkg_config() {
+ yaskkserv_update
+}