summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-10-19 22:55:39 +0200
committerMike Gilbert <floppym@gentoo.org>2017-10-23 13:24:42 -0400
commit2617a47340d7f62c31d7a061783b37188eb55425 (patch)
treec87f81053df3022eb0f18106d7a808a575ade473 /app-i18n
parentapp-i18n/fcitx-sunpinyin: Version bump (0.4.2). (diff)
downloadgentoo-2617a47340d7f62c31d7a061783b37188eb55425.tar.gz
gentoo-2617a47340d7f62c31d7a061783b37188eb55425.tar.bz2
gentoo-2617a47340d7f62c31d7a061783b37188eb55425.zip
app-i18n/fcitx-sunpinyin: Add live ebuild.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild
new file mode 100644
index 000000000000..20c11e0aec3f
--- /dev/null
+++ b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-sunpinyin"
+fi
+
+DESCRIPTION="Chinese SunPinyin input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-sunpinyin"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/sunpinyin-2.0.4_alpha:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}