summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-10-19 22:51:25 +0200
committerMike Gilbert <floppym@gentoo.org>2017-10-23 13:24:42 -0400
commit36d8e072455148108abf2fb9645dedf8f29ce47b (patch)
tree696224c6af84f48eb028b8936c4d8a554f02170f /app-i18n
parentapp-i18n/fcitx-hangul: Update metadata.xml. (diff)
downloadgentoo-36d8e072455148108abf2fb9645dedf8f29ce47b.tar.gz
gentoo-36d8e072455148108abf2fb9645dedf8f29ce47b.tar.bz2
gentoo-36d8e072455148108abf2fb9645dedf8f29ce47b.zip
app-i18n/fcitx-rime: Version bump (0.3.2).
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-rime/Manifest1
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/Manifest b/app-i18n/fcitx-rime/Manifest
index dba3d2464649..37e7f476ec14 100644
--- a/app-i18n/fcitx-rime/Manifest
+++ b/app-i18n/fcitx-rime/Manifest
@@ -1,2 +1,3 @@
DIST fcitx-rime-0.2.0.tar.xz 8116 SHA256 e4bc9243abffd1851b4ee19c88d7c2b32ede134aeda60aee930388f9f33ca269 SHA512 3f02d7bf0e47981e7a135ccaa46653be319d1bb716bd939b50419e47b8d3c07b347434e8529522d4266bd5fac6dbc2cdc1bfd4b7ea0607250023f70f97006228 WHIRLPOOL 7dbdcd3ac90f2d901b5b5c06541b9f6f1debf4ad833c2ddacb840dbd80a4443725fc7bdb41ad2261db8f34cb0dc77fe3d5f0c45e69a0a056618518007c1c708e
DIST fcitx-rime-0.3.1.tar.xz 39648 SHA256 3ca74de4d20e8fd0e67eb4ccae8af3790bb1f557f183c2af32cb45f371e8521d SHA512 5d3c8fc119e1a104987a7876f3b1c54da074e34ce9feb9c02efa7c9cfd788c3735680a03cdb50d69a5512a9f075c7326bdc267cf076daa916238898da81d2388 WHIRLPOOL ed8f4ed563dfbe01aaac71bb847d4a9b641b041f9916c8c6c34a444202ac00720ebe4274c30906141b103fbbf55d7ce045cef094792c1fffadae03dd0ce73f7a
+DIST fcitx-rime-0.3.2.tar.xz 40960 SHA256 f97ea6f515fcc5f526cc25dce3d4ba05fa1c83001f68502d6c284ba39cd5a82d SHA512 8c6d845b0899d9b8b9b41b895abd5c1b8916856b71f529aabd08d1c27a2b09bb5a9343912d088da460c2e22da0a3ce759a34fd13099a149bb8cd1ff4eafe29f1 WHIRLPOOL 57b979a8ef850ec1c4f85b6b3b5841ad17f73c1861223d033c7b79db6c301f1f0da13c4ab53661a4899ad13db40c424f3c1b257dd2058e28fe89f6d57c2bf17b
diff --git a/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild b/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
new file mode 100644
index 000000000000..c11c94262a49
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-rime"
+fi
+
+DESCRIPTION="Chinese RIME input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-rime"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/librime-1.0.0:=
+ app-i18n/rime-data
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DRIME_DATA_DIR="${EPREFIX}/usr/share/rime-data"
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}