summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-16 13:40:30 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-16 13:40:30 +0200
commit36ea03e2c553ebbd7deb00bfd3d35c4548b7c460 (patch)
treec5787858db5c69c969f32e279b2c76bc877a8358 /app-i18n
parentapp-i18n/qkc: Port to EAPI 7 (diff)
downloadgentoo-36ea03e2c553ebbd7deb00bfd3d35c4548b7c460.tar.gz
gentoo-36ea03e2c553ebbd7deb00bfd3d35c4548b7c460.tar.bz2
gentoo-36ea03e2c553ebbd7deb00bfd3d35c4548b7c460.zip
app-i18n/scim-input-pad: Port to EAPI 7
Closes: https://bugs.gentoo.org/742041 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild29
-rw-r--r--app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild29
2 files changed, 34 insertions, 24 deletions
diff --git a/app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild b/app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild
index 4f87c9cc0793..d6613ab82f8b 100644
--- a/app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild
+++ b/app-i18n/scim-input-pad/scim-input-pad-0.1.3.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
inherit autotools
@@ -14,29 +14,35 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"
-RDEPEND=">=app-i18n/scim-1.2.0
+RDEPEND="
+ >=app-i18n/scim-1.2.0
>=x11-libs/gtk+-2.6.0:2"
-
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=dev-util/intltool-0.33
virtual/pkgconfig"
src_prepare() {
- rm "${S}"/m4/intltool.m4 || die
+ default
+
+ rm m4/intltool.m4 || die
eautoreconf
}
src_configure() {
- econf $(use_enable nls)
+ econf \
+ --disable-static \
+ $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc ChangeLog README
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
-
elog
elog "The SCIM input pad should be startable from the SCIM (and Skim)"
elog "systray icon right click menu. You will have to restart SCIM"
@@ -49,7 +55,6 @@ pkg_postinst() {
elog "table, from the SCIM Input Pad interface."
elog
elog "To add new characters to the tables, see the documentation"
- elog "(README file in /usr/share/doc/${PF})."
+ elog "(README file in ${EROOT}/usr/share/doc/${PF})."
elog
-
}
diff --git a/app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild b/app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild
index 65ab96d29a17..0cbb2a9701e8 100644
--- a/app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild
+++ b/app-i18n/scim-input-pad/scim-input-pad-0.1.3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
inherit autotools
@@ -14,29 +14,35 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
-RDEPEND=">=app-i18n/scim-1.2.0
+RDEPEND="
+ >=app-i18n/scim-1.2.0
>=x11-libs/gtk+-2.6.0:2"
-
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=dev-util/intltool-0.33
virtual/pkgconfig"
src_prepare() {
- rm "${S}"/m4/intltool.m4 || die
+ default
+
+ rm m4/intltool.m4 || die
eautoreconf
}
src_configure() {
- econf $(use_enable nls)
+ econf \
+ --disable-static \
+ $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc ChangeLog README
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
-
elog
elog "The SCIM input pad should be startable from the SCIM (and Skim)"
elog "systray icon right click menu. You will have to restart SCIM"
@@ -49,7 +55,6 @@ pkg_postinst() {
elog "table, from the SCIM Input Pad interface."
elog
elog "To add new characters to the tables, see the documentation"
- elog "(README file in /usr/share/doc/${PF})."
+ elog "(README file in ${EROOT}/usr/share/doc/${PF})."
elog
-
}