summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-12-18 22:39:14 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-12-18 22:39:14 +0900
commit37b075612bb3748e7c9ca5c6684df653f68e96db (patch)
tree75838717a6b3e40de00f7dc2b20b5dedf4548118 /app-i18n
parentprofiles/arch.list: fix repoman, add arm64-macos, drop x86-cygwin (diff)
downloadgentoo-37b075612bb3748e7c9ca5c6684df653f68e96db.tar.gz
gentoo-37b075612bb3748e7c9ca5c6684df653f68e96db.tar.bz2
gentoo-37b075612bb3748e7c9ca5c6684df653f68e96db.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.10.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 6754bdb51a04..2e84cbc917be 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.10.1.tar.gz 9449495 BLAKE2B 36e52d3e6349a89a1202429f7068221dc75dc0072d9e49424cf410ab12c2e732b9ea9fc54a2bbbfe386f2687535b9e0d46e5567f1572c42cf7fe98243c234a38 SHA512 d4262d7bec0b65919f5d25c97b319a48808d1257ea0697163bcaae238870d57640ed8fb44d423abb844416e1c99c130b1d6d5813a0edfa849afc762929e61f66
+DIST ibus-typing-booster-2.10.2.tar.gz 9433317 BLAKE2B 883639c6f6551b0e27e9ae45ba38320b465aeab9e43c6d848acff42fe74c670a6c0ea119256503267e5da7d94de2fbb8710b2d5c5de3a169aff095e0aa3570de SHA512 168ff2528e9b57120936dc69b6d8f32d495508de7e5a0cec9782b1b108b4acca9ba42c9a2f680f2b56c4ec01eae805b22cc5ba34e1a59c449715f589be51c542
DIST ibus-typing-booster-2.9.7.tar.gz 8833452 BLAKE2B 4c4f33bcff2fa9e20afeccf242bec1a6e11fca0b5cb515b2c2dce7ef2401c092a7197a6637e2ca72d4c1bacd694860c07ae645a313e41cd879d6bde8c1736d12 SHA512 984beacdd6b853e074127372a912442ba1dbc536ecf194a34d03025277b9d6277e967e63a9bdcd1620f5094965a191297ccae9adbff2d54d1cd474437a1ec16b
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.10.2.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.10.2.ebuild
new file mode 100644
index 000000000000..decf9c7acdb5
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.10.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}