summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-12-07 06:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-12-07 13:14:28 -0500
commit3d096d33ac39ade3972f4cbc03bc21e93fa6ddc4 (patch)
treeb920a78f679bf2338a3426fcc6aa1f656f833fa5 /app-i18n
parentapp-i18n/ibus-pinyin: Add support for Python 3.9. (diff)
downloadgentoo-3d096d33ac39ade3972f4cbc03bc21e93fa6ddc4.tar.gz
gentoo-3d096d33ac39ade3972f4cbc03bc21e93fa6ddc4.tar.bz2
gentoo-3d096d33ac39ade3972f4cbc03bc21e93fa6ddc4.zip
app-i18n/ibus-pinyin: Use slotted Lua.
Closes: https://bugs.gentoo.org/752555 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r4.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r4.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r4.ebuild
index c52c0098b4cd..2c2bec4054b7 100644
--- a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r4.ebuild
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r4.ebuild
@@ -2,19 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+LUA_COMPAT=(lua5-1)
PYTHON_COMPAT=(python3_{6,7,8,9})
-inherit autotools python-single-r1
+inherit autotools lua-single python-single-r1
DESCRIPTION="Chinese Pinyin and Bopomofo engines for IBus"
-HOMEPAGE="https://github.com/ibus/ibus/wiki"
+HOMEPAGE="https://github.com/ibus/ibus-pinyin"
SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/ibus/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="boost lua nls"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ lua? ( ${LUA_REQUIRED_USE} )"
RDEPEND="${PYTHON_DEPS}
app-i18n/pyzy
@@ -24,7 +26,7 @@ RDEPEND="${PYTHON_DEPS}
dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
')
boost? ( dev-libs/boost )
- lua? ( =dev-lang/lua-5.1*:0= )
+ lua? ( ${LUA_DEPS} )
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
dev-util/intltool
@@ -38,6 +40,14 @@ PATCHES=(
"${FILESDIR}"/${P}-python3.patch
)
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
src_prepare() {
default
eautoreconf