summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-06-25 14:18:38 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-06-25 14:18:38 +0900
commit46427f71c448dadf28de90945d2a5337c31a9bc9 (patch)
tree0abdc3190048229a5694f662aeadc666b4b0b910 /app-i18n
parentapp-i18n/skkfep: update to EAPI 6 (diff)
downloadgentoo-46427f71c448dadf28de90945d2a5337c31a9bc9.tar.gz
gentoo-46427f71c448dadf28de90945d2a5337c31a9bc9.tar.bz2
gentoo-46427f71c448dadf28de90945d2a5337c31a9bc9.zip
app-i18n/skkfep: fix segfault
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/skkfep/files/skkfep-system-dic.patch13
-rw-r--r--app-i18n/skkfep/skkfep-0.87-r1.ebuild5
2 files changed, 17 insertions, 1 deletions
diff --git a/app-i18n/skkfep/files/skkfep-system-dic.patch b/app-i18n/skkfep/files/skkfep-system-dic.patch
new file mode 100644
index 000000000000..ba57a2a41f0b
--- /dev/null
+++ b/app-i18n/skkfep/files/skkfep-system-dic.patch
@@ -0,0 +1,13 @@
+--- a/kkconv.c
++++ b/kkconv.c
+@@ -660,7 +660,9 @@
+ flushOut(l);
+ #ifdef USE_SERVER
+ if (!CandFromServer) {
+- selectCand(FirstCandEntry,CurrentCand);
++ if (FirstCandEntry != NULL) {
++ selectCand(FirstCandEntry,CurrentCand);
++ }
+ }
+ else if (NetLearnMode != LearnOff) {
+ if (CurrentCand->dicitem == NULL) {
diff --git a/app-i18n/skkfep/skkfep-0.87-r1.ebuild b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
index 57a0760d5339..a3e53f72d619 100644
--- a/app-i18n/skkfep/skkfep-0.87-r1.ebuild
+++ b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
@@ -20,7 +20,10 @@ DEPEND="sys-apps/sed
RDEPEND="sys-libs/ncurses:=
app-i18n/skk-jisyo"
-PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-system-dic.patch
+)
DOCS=( README HISTORY TODO )
src_prepare() {