summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-13 22:07:01 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-15 12:24:57 -0700
commit569bfe817147fdf3f0590291126d2898260e2fe3 (patch)
tree130b0d563551eeb81cf00fa8b0aad03311f1f13e /app-i18n
parentapp-i18n/ibus: use BDEPEND with EAPI 7, fix cross-compiling (diff)
downloadgentoo-569bfe817147fdf3f0590291126d2898260e2fe3.tar.gz
gentoo-569bfe817147fdf3f0590291126d2898260e2fe3.tar.bz2
gentoo-569bfe817147fdf3f0590291126d2898260e2fe3.zip
app-i18n/ibus: Rename IUSE=kde to IUSE=appindicator
And remove dependence on dev-qt/qtgui, as it was removed in v1.5.23, upstream commit aa3a9f05 ("ui/gtk3: Delete deprecated ENABLE_APPINDICATOR_ENGINE_ICON check") Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus/ibus-1.5.26.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-i18n/ibus/ibus-1.5.26.ebuild b/app-i18n/ibus/ibus-1.5.26.ebuild
index 81c38c2f452f..889cbf087411 100644
--- a/app-i18n/ibus/ibus-1.5.26.ebuild
+++ b/app-i18n/ibus/ibus-1.5.26.ebuild
@@ -19,11 +19,11 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="+X +emoji +gtk +gtk2 +introspection kde nls +python systemd test +unicode vala wayland"
+IUSE="+X appindicator +emoji +gtk +gtk2 +introspection nls +python systemd test +unicode vala wayland"
RESTRICT="!test? ( test )"
REQUIRED_USE="emoji? ( gtk )
gtk2? ( gtk )
- kde? ( gtk )
+ appindicator? ( gtk )
python? (
${PYTHON_REQUIRED_USE}
introspection
@@ -49,7 +49,6 @@ DEPEND="
gtk2? ( x11-libs/gtk+:2 )
)
introspection? ( dev-libs/gobject-introspection )
- kde? ( dev-qt/qtgui:5 )
nls? ( virtual/libintl )
python? (
${PYTHON_DEPS}
@@ -89,7 +88,7 @@ src_prepare() {
tools/main.vala \
ui/gtk3/panel.vala
fi
- if ! use kde; then
+ if ! use appindicator; then
touch ui/gtk3/panel.vala
fi
if [[ -n ${GENTOO_VER} ]]; then
@@ -138,6 +137,7 @@ src_configure() {
local myconf=(
$(use_enable X xim)
+ $(use_enable appindicator)
$(use_enable emoji emoji-dict)
$(use_with emoji unicode-emoji-dir "${unicodedir}"/emoji)
$(use_with emoji emoji-annotation-dir "${unicodedir}"/cldr/common/annotations)
@@ -145,7 +145,6 @@ src_configure() {
$(use_enable gtk ui)
$(use_enable gtk2)
$(use_enable introspection)
- $(use_enable kde appindicator)
$(use_enable nls)
$(use_enable systemd systemd-services)
$(use_enable test tests)