summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2022-01-28 00:00:00 +0000
committerYixun Lan <dlan@gentoo.org>2022-01-29 23:18:48 +0800
commit57fa9afa0c21d48c99e86263b3af95bc33068a6c (patch)
treeb7450060712bc971c270883b422c9bef791de534 /app-i18n
parentapp-i18n/mozc: Add support for Python 3.10 (diff)
downloadgentoo-57fa9afa0c21d48c99e86263b3af95bc33068a6c.tar.gz
gentoo-57fa9afa0c21d48c99e86263b3af95bc33068a6c.tar.bz2
gentoo-57fa9afa0c21d48c99e86263b3af95bc33068a6c.zip
app-i18n/mozc: Use EAPI="8"
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/mozc/mozc-2.23.2815.102.ebuild2
-rw-r--r--app-i18n/mozc/mozc-2.26.4220_p20201212102434_p20201219202429.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/app-i18n/mozc/mozc-2.23.2815.102.ebuild b/app-i18n/mozc/mozc-2.23.2815.102.ebuild
index 07c327fea709..b859d8cf38a2 100644
--- a/app-i18n/mozc/mozc-2.23.2815.102.ebuild
+++ b/app-i18n/mozc/mozc-2.23.2815.102.ebuild
@@ -1,7 +1,7 @@
# Copyright 2010-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
PYTHON_COMPAT=( python3_{8..10} )
inherit elisp-common multiprocessing python-any-r1 toolchain-funcs
diff --git a/app-i18n/mozc/mozc-2.26.4220_p20201212102434_p20201219202429.ebuild b/app-i18n/mozc/mozc-2.26.4220_p20201212102434_p20201219202429.ebuild
index 8e6ad82d5b17..8ac56d51c502 100644
--- a/app-i18n/mozc/mozc-2.26.4220_p20201212102434_p20201219202429.ebuild
+++ b/app-i18n/mozc/mozc-2.26.4220_p20201212102434_p20201219202429.ebuild
@@ -1,7 +1,7 @@
# Copyright 2010-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
PYTHON_COMPAT=( python3_{8..10} )
inherit elisp-common multiprocessing python-any-r1 toolchain-funcs
@@ -134,7 +134,7 @@ src_unpack() {
if use fcitx4; then
unpack fcitx-${PN}-${PV%%_p*}-${FCITX_MOZC_DATE}.tar.gz
- mv mozc-${FCITX_MOZC_GIT_REVISION} fcitx-${PN}
+ mv mozc-${FCITX_MOZC_GIT_REVISION} fcitx-${PN} || die
fi
fi
}