summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-03-04 22:14:12 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-03-04 22:14:12 +0900
commit794f963dd11ea597bdfae92797182547ac9c88fb (patch)
treea61894f5c9a78d1f4096a4199932941c70a64b6e /app-i18n
parentapp-i18n/ibus-m17n: drop old (diff)
downloadgentoo-794f963dd11ea597bdfae92797182547ac9c88fb.tar.gz
gentoo-794f963dd11ea597bdfae92797182547ac9c88fb.tar.bz2
gentoo-794f963dd11ea597bdfae92797182547ac9c88fb.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.10.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 2feabea9c749..e8e2f30041ee 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.10.1.tar.gz 9449495 BLAKE2B 36e52d3e6349a89a1202429f7068221dc75dc0072d9e49424cf410ab12c2e732b9ea9fc54a2bbbfe386f2687535b9e0d46e5567f1572c42cf7fe98243c234a38 SHA512 d4262d7bec0b65919f5d25c97b319a48808d1257ea0697163bcaae238870d57640ed8fb44d423abb844416e1c99c130b1d6d5813a0edfa849afc762929e61f66
DIST ibus-typing-booster-2.10.2.tar.gz 9433317 BLAKE2B 883639c6f6551b0e27e9ae45ba38320b465aeab9e43c6d848acff42fe74c670a6c0ea119256503267e5da7d94de2fbb8710b2d5c5de3a169aff095e0aa3570de SHA512 168ff2528e9b57120936dc69b6d8f32d495508de7e5a0cec9782b1b108b4acca9ba42c9a2f680f2b56c4ec01eae805b22cc5ba34e1a59c449715f589be51c542
+DIST ibus-typing-booster-2.10.5.tar.gz 9448121 BLAKE2B 32e332df5e68a81c4f86df298389bb1fd9daf97b1f281bdc150183bd939a97021540aa81db5fa94ee3890c9b9a031a8eb75241da3716763ed6262fc5d5b3fb9d SHA512 f3bc5536874227b5482e46a097ac634a522651b3d200b33207705f5b1d87b8894dd962e19c389281fa5f32c1edbf3186dbfba12d718cbc6fa159d648bc622bf6
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.10.5.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.10.5.ebuild
new file mode 100644
index 000000000000..4547ea3abfbb
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.10.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}