summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-07 23:10:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-08 00:56:49 +0100
commit7def0ba1bb0def667a74e7298fb877bd86ed7c23 (patch)
tree9f7f14a9aa73d19fcf101842bd828a8297723e8e /app-i18n
parentnet-firewall/pglinux: EAPI-7, gnome2-utils->xdg-utils, use qmake-utils (diff)
downloadgentoo-7def0ba1bb0def667a74e7298fb877bd86ed7c23.tar.gz
gentoo-7def0ba1bb0def667a74e7298fb877bd86ed7c23.tar.bz2
gentoo-7def0ba1bb0def667a74e7298fb877bd86ed7c23.zip
app-i18n/uim: EAPI-7, use qmake-utils, sort some deps
Closes: https://bugs.gentoo.org/764329 Closes: https://bugs.gentoo.org/712098 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/uim/uim-1.8.8.ebuild54
1 files changed, 31 insertions, 23 deletions
diff --git a/app-i18n/uim/uim-1.8.8.ebuild b/app-i18n/uim/uim-1.8.8.ebuild
index 3ed23be0370a..2f6435d4dcfe 100644
--- a/app-i18n/uim/uim-1.8.8.ebuild
+++ b/app-i18n/uim/uim-1.8.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit autotools elisp-common flag-o-matic gnome2-utils
+inherit autotools elisp-common flag-o-matic gnome2-utils qmake-utils
DESCRIPTION="A multilingual input method framework"
HOMEPAGE="https://github.com/uim/uim"
@@ -19,26 +19,17 @@ REQUIRED_USE="gtk? ( X )
qt5? ( X )
xft? ( X )"
-CDEPEND="!dev-scheme/sigscheme
- X? (
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXft
- x11-libs/libXrender
- x11-libs/libXt
- )
+COMMON_DEPEND="
anthy? ( app-i18n/anthy )
canna? ( app-i18n/canna )
curl? ( net-misc/curl )
eb? ( dev-libs/eb )
emacs? ( >=app-editors/emacs-23.1:* )
expat? ( dev-libs/expat )
- libffi? ( dev-libs/libffi:= )
gtk? ( x11-libs/gtk+:3 )
gtk2? ( x11-libs/gtk+:2 )
libedit? ( dev-libs/libedit )
+ libffi? ( dev-libs/libffi:= )
libnotify? ( x11-libs/libnotify )
m17n-lib? ( dev-libs/m17n-lib )
ncurses? ( sys-libs/ncurses:0= )
@@ -49,13 +40,22 @@ CDEPEND="!dev-scheme/sigscheme
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${CDEPEND}
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig
- X? ( x11-base/xorg-proto )"
-RDEPEND="${CDEPEND}
+ )
+ X? (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ X? ( x11-base/xorg-proto )
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-scheme/sigscheme
X? (
media-fonts/font-sony-misc
l10n_ja? (
@@ -77,7 +77,13 @@ RDEPEND="${CDEPEND}
)
)
l10n_zh-TW? ( media-fonts/intlfonts )
- )"
+ )
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
@@ -86,6 +92,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-zh-TW.patch
"${FILESDIR}"/${P}-fno-common.patch
)
+
DOCS=( AUTHORS NEWS README RELNOTE doc )
AT_NO_RECURSIVE="yes"
@@ -121,6 +128,7 @@ src_configure() {
$(use_enable nls)
$(use_with qt5)
$(use_with qt5 qt5-immodule)
+ _QMAKE5=$(qt5_get_bindir)/qmake
$(use_with skk)
$(use_with sqlite sqlite3)
$(use_enable ssl openssl)
@@ -214,7 +222,7 @@ pkg_postinst() {
if use emacs; then
elisp-site-regen
- echo
+ elog
elog "uim is autoloaded with Emacs with a minimal set of features:"
elog "There is no keybinding defined to call it directly, so please"
elog "create one yourself and choose an input method."