summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-11-19 06:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-11-22 14:31:54 -0500
commit8cfa126075f915b07cefa3b7730c3e30503c8f67 (patch)
treec6808661991fa8cb6a3db7428b9e47900d391985 /app-i18n
parentapp-i18n/opencc: Stop using no longer needed patch. (diff)
downloadgentoo-8cfa126075f915b07cefa3b7730c3e30503c8f67.tar.gz
gentoo-8cfa126075f915b07cefa3b7730c3e30503c8f67.tar.bz2
gentoo-8cfa126075f915b07cefa3b7730c3e30503c8f67.zip
app-i18n/opencc: Add proper usage of python-any-r1.eclass.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/opencc/opencc-1.0.5.ebuild6
-rw-r--r--app-i18n/opencc/opencc-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/app-i18n/opencc/opencc-1.0.5.ebuild b/app-i18n/opencc/opencc-1.0.5.ebuild
index fea4bcd352c5..6e3c86035fde 100644
--- a/app-i18n/opencc/opencc-1.0.5.ebuild
+++ b/app-i18n/opencc/opencc-1.0.5.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
-inherit cmake
+inherit cmake python-any-r1
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -25,7 +26,8 @@ KEYWORDS="amd64 arm64 hppa ppc ppc64 sparc x86"
IUSE="doc test"
RESTRICT="!test? ( test )"
-BDEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )"
DEPEND=""
RDEPEND=""
diff --git a/app-i18n/opencc/opencc-9999.ebuild b/app-i18n/opencc/opencc-9999.ebuild
index 9fb2129d45dc..bcf43765ab11 100644
--- a/app-i18n/opencc/opencc-9999.ebuild
+++ b/app-i18n/opencc/opencc-9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
-inherit cmake
+inherit cmake python-any-r1
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -25,7 +26,8 @@ KEYWORDS=""
IUSE="doc test"
RESTRICT="!test? ( test )"
-BDEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )"
DEPEND=""
RDEPEND=""