summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-12-14 10:55:22 +0100
committerUlrich Müller <ulm@gentoo.org>2019-12-14 10:57:15 +0100
commit936a620678f6dcdeec3293870a20f4bc19b6f311 (patch)
treec3dfc0c62d890cc1bbcec040e8838926a5bc2842 /app-i18n
parentsys-devel/clang-runtime: Bump to 9.0.1_rc3 (diff)
downloadgentoo-936a620678f6dcdeec3293870a20f4bc19b6f311.tar.gz
gentoo-936a620678f6dcdeec3293870a20f4bc19b6f311.tar.bz2
gentoo-936a620678f6dcdeec3293870a20f4bc19b6f311.zip
app-i18n/man-pages-de: Fix file collision with sys-process/procps.
Bug: https://bugs.gentoo.org/702276 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/man-pages-de/man-pages-de-2.12-r1.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/app-i18n/man-pages-de/man-pages-de-2.12-r1.ebuild b/app-i18n/man-pages-de/man-pages-de-2.12-r1.ebuild
new file mode 100644
index 000000000000..5901e1eda028
--- /dev/null
+++ b/app-i18n/man-pages-de/man-pages-de-2.12-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN/-/}-v${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="https://salsa.debian.org/manpages-de-team/manpages-de"
+SRC_URI="https://salsa.debian.org/manpages-de-team/manpages-de/-/archive/v${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+BDEPEND="app-text/po4a"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ sed '/gzip --best/d' -i po/Makefile.am || die
+
+ # sys-apps/shadow has it's own translated man-page for this
+ local manpage
+ local noinst_manpages=(
+ upstream/debian-unstable/man1/groups.1
+ po/man1/free.1.po
+ po/man1/groups.1.po
+ po/man1/su.1.po
+ po/man1/uptime.1.po
+ )
+ for manpage in ${noinst_manpages[@]} ; do
+ rm "${manpage}" || die
+ done
+
+ # Use the same compression as every other manpage
+ local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+ local PORTAGE_COMPRESS_FLAGS_LOCAL=${PORTAGE_COMPRESS_FLAGS}
+ if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2|gzip)
+ PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+ ;;
+ esac
+ fi
+
+ # Fix source files for symlinks
+ local LINKSOURCE
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2)
+ for LINKSOURCE in upstream/*/links.txt ; do
+ sed -i -e 's/\.gz/\.bz2/g' "${LINKSOURCE}" || die
+ done
+ ;;
+ gzip)
+ # pass
+ ;;
+ xz)
+ for LINKSOURCE in upstream/*/links.txt ; do
+ sed -i -e 's/\.gz/\.xz/g' "${LINKSOURCE}" || die
+ done
+ ;;
+ *)
+ ewarn "Unexpected compression command ${PORTAGE_COMPRESS} found, symlinks will not work."
+ ;;
+ esac
+
+ eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake mandir="${ED}"/usr/share/man install
+ dodoc CHANGES.md README.md
+}