summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-10 22:38:20 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-10 22:40:35 +0900
commitbe653637794466b1077cc5f205629c70d1908db8 (patch)
tree1ead91745b3fc10f256752944c45807a2a75f612 /app-i18n
parentdev-python/quex: move unpacker to BDEPEND (diff)
downloadgentoo-be653637794466b1077cc5f205629c70d1908db8.tar.gz
gentoo-be653637794466b1077cc5f205629c70d1908db8.tar.bz2
gentoo-be653637794466b1077cc5f205629c70d1908db8.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index c6c433fc2458..99215a6ab9aa 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.9.0.tar.gz 8191076 BLAKE2B 4b0e53679b907fce56361c60aed2d50f0ac3bef422f9c56b4b5ca8733734c0341f90dfbcf2a9db747a801d999a49198de2b091badf8efe141d22fddb9b35ec6c SHA512 33e0c53e3f16e312eee7db2395d0a5506150e60a47882a7531c9d082e0ca405aabd922b4774a507399d31f38feed78fb87a09efc5550f08dd3794703f1fab235
DIST ibus-typing-booster-2.9.4.tar.gz 8222228 BLAKE2B 8ba79ceaff6cd5ce37d093b08438a22ffb7b1295bba6d0b3af141b5804e89d04807d14fa5c5ce959ff728d76fcc5e60c0a51f113baa172710d59866733bd9741 SHA512 9c323301deccec0904cb2a2e34015ef11885ecd635ddb99afc6811a7f684dca448a026301155ae26fe0a38c00ca0a4d714ff933c39a60e4299434cfbca455d58
+DIST ibus-typing-booster-2.9.5.tar.gz 8236281 BLAKE2B 749890cc3477db890603c9a700bff1a097fd2cd09d01477f319658c65c73688903171e49a0284176ce396d83587ef23a067a0aabe81c57bf70479050a15e8c80 SHA512 58db7d7e687512d8c436b23c28e1c614d56f486de13153f5ddfddecf32595f6de8c8289273b288c1df857dac5577df3eea48ca900b709a13b9c91b2e0ec21286
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.5.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.5.ebuild
new file mode 100644
index 000000000000..ed1abe745449
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}