summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:11:25 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:03 +0000
commitc16eab58d376d28bf18853359f56624521c2c7e9 (patch)
treef74b5148f1632d7ed1cc7eb380f3f6724a2cb39a /app-i18n
parentapp-i18n/canna: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-c16eab58d376d28bf18853359f56624521c2c7e9.tar.gz
gentoo-c16eab58d376d28bf18853359f56624521c2c7e9.tar.bz2
gentoo-c16eab58d376d28bf18853359f56624521c2c7e9.zip
app-i18n/freewnn: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/freewnn/freewnn-1.1.1_alpha23.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-i18n/freewnn/freewnn-1.1.1_alpha23.ebuild b/app-i18n/freewnn/freewnn-1.1.1_alpha23.ebuild
index e6dae1fef125..70978e2d84fb 100644
--- a/app-i18n/freewnn/freewnn-1.1.1_alpha23.ebuild
+++ b/app-i18n/freewnn/freewnn-1.1.1_alpha23.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
+inherit toolchain-funcs
+
MY_P="FreeWnn-${PV/_alpha/-a0}"
DESCRIPTION="Network-Extensible Kana-to-Kanji Conversion System"
@@ -50,7 +52,7 @@ src_configure() {
--disable-cWnn \
--disable-kWnn \
--disable-traditional-layout \
- --with-term-libs="$(pkg-config --libs ncurses)"
+ --with-term-libs="$($(tc-getPKG_CONFIG) --libs ncurses)"
}
src_compile() {