summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraham Ramsey <graham.ramsey@gmail.com>2018-06-27 09:50:08 +0100
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 09:56:16 +0100
commitc38eb5b5d3cd939c81a57cc606553cb5ec10bd3a (patch)
tree9e83b962c310ebd6fd656f4b4814d1642e9f71c1 /app-i18n
parentmedia-gfx/ephoto: new package (diff)
downloadgentoo-c38eb5b5d3cd939c81a57cc606553cb5ec10bd3a.tar.gz
gentoo-c38eb5b5d3cd939c81a57cc606553cb5ec10bd3a.tar.bz2
gentoo-c38eb5b5d3cd939c81a57cc606553cb5ec10bd3a.zip
app-i18n/ibus-libpinyin: Version bump 1.10.0 & fix boost configure
1.9.3-r1 - This patches issue with latest GCC on configure with boost 1.10.0 - This includes above patch, and also update to new major version I submitted the patch/fix upstream as pull request https://github.com/libpinyin/ibus-libpinyin/pull/134 and it has been merged (basically updating the boost.m4 macro to latest) 1.10.0 has additional changes as upstream has moved configuration settings to gsettings (now requires gnome2_utils eclass) Closes: https://bugs.gentoo.org/659328 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9050 Closes: https://bugs.gentoo.org/659816
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-libpinyin/Manifest2
-rw-r--r--app-i18n/ibus-libpinyin/ibus-libpinyin-1.10.0.ebuild64
-rw-r--r--app-i18n/ibus-libpinyin/ibus-libpinyin-1.9.3-r1.ebuild52
3 files changed, 118 insertions, 0 deletions
diff --git a/app-i18n/ibus-libpinyin/Manifest b/app-i18n/ibus-libpinyin/Manifest
index b11dec5e3465..afa6c68962d7 100644
--- a/app-i18n/ibus-libpinyin/Manifest
+++ b/app-i18n/ibus-libpinyin/Manifest
@@ -1,2 +1,4 @@
+DIST boost.282b1e01f5bc5ae94347474fd8c35cb2f7a7e65d.m4 55907 BLAKE2B 16ac81094457c80b418109104139c1604e38ec58d6065474cc512668601f12896c4d470fe15c9a366a5ec63d50135265df71f28f4202fa283231879fafb0efbc SHA512 382c7f8a94059ae9816783b12c2d27ee6ca69e23ef7085bf2ee5a31109e6ab0c3d0b0042a3dc290b89276b6315d767aedf073dca390fa688a9aae07e837f83c9
+DIST ibus-libpinyin-1.10.0.tar.gz 1693440 BLAKE2B 5e0d9debddfbb81fcb45ac86d1fe8fb1220a50c527222fb3c3431149231f41dcc59ae87da9ae9485e2585f0e3051ac4d1792407ba62d90e5e0323c482d52318f SHA512 c9fdc28562714bddc889805e1d439a7dd425f721a8236b8f8ec4727ce24e5053693b3e5bd9b06ced22ceb66bc7621715f7ee52e00af3b8b113503a5ce6963ca0
DIST ibus-libpinyin-1.9.2.tar.gz 1693247 BLAKE2B a887be2a11406420e86cf1e7f76f8d8c06cbffa62a0ab42d450015965c24accab51164ed18cdc8e24f26edf03676603a691c907e00722efc24e947919345570f SHA512 008390049b0186b7163cfd8857806715dd78235fc1e35a89d4b58a38eb7f292b643d48f502c0c924512a9f5a96d2581f577d6a9ec3b660d05d9a4adcde970430
DIST ibus-libpinyin-1.9.3.tar.gz 1692251 BLAKE2B 6f23a8838f90c082a43fc2922bcaf13ecf287fdfb898f1ba213739f8e2f65ff9a68bdc57cf8f82e73e2c5e1569f1209b8294b45c30c5c3b7e32287b73394ddc7 SHA512 cad3d8415e0c206cbd2eb606ea04b5861e10c3a5f614d90bbba29b751fcc978e2ce1a8a000ceb8cc98de1afcc145ea62b5ee8e9d34e4184bccc487225b34ab1a
diff --git a/app-i18n/ibus-libpinyin/ibus-libpinyin-1.10.0.ebuild b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.10.0.ebuild
new file mode 100644
index 000000000000..7e9cb612b601
--- /dev/null
+++ b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.10.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit autotools python-single-r1 gnome2-utils
+
+BOOST_M4_GIT_VERSION=282b1e01f5bc5ae94347474fd8c35cb2f7a7e65d
+
+DESCRIPTION="Intelligent Pinyin and Bopomofo input methods based on LibPinyin for IBus"
+HOMEPAGE="https://github.com/libpinyin/ibus-libpinyin https://sourceforge.net/projects/libpinyin/"
+SRC_URI="https://github.com/libpinyin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ boost? ( https://github.com/tsuna/boost.m4/raw/${BOOST_M4_GIT_VERSION}/build-aux/boost.m4 -> boost.${BOOST_M4_GIT_VERSION}.m4 )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua opencc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ >=app-i18n/libpinyin-2.1.0:=
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ boost? ( dev-libs/boost:= )
+ lua? ( dev-lang/lua:0 )
+ opencc? ( app-i18n/opencc:= )"
+
+DEPEND="${RDEPEND}
+ virtual/libintl
+ virtual/pkgconfig"
+
+src_prepare() {
+ if use boost; then
+ cp "${DISTDIR}/boost.${BOOST_M4_GIT_VERSION}.m4" "m4/boost.m4" \
+ || die "copying newer version of boost.m4 file failed"
+ fi
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-english-input-mode \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable opencc)
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/app-i18n/ibus-libpinyin/ibus-libpinyin-1.9.3-r1.ebuild b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..04c2251e7b30
--- /dev/null
+++ b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.9.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit autotools python-single-r1
+
+BOOST_M4_GIT_VERSION=282b1e01f5bc5ae94347474fd8c35cb2f7a7e65d
+
+DESCRIPTION="Intelligent Pinyin and Bopomofo input methods based on LibPinyin for IBus"
+HOMEPAGE="https://github.com/libpinyin/ibus-libpinyin https://sourceforge.net/projects/libpinyin/"
+SRC_URI="https://github.com/libpinyin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ boost? ( https://github.com/tsuna/boost.m4/raw/${BOOST_M4_GIT_VERSION}/build-aux/boost.m4 -> boost.${BOOST_M4_GIT_VERSION}.m4 )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua opencc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ >=app-i18n/libpinyin-2.1.0:=
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ boost? ( dev-libs/boost:= )
+ lua? ( dev-lang/lua:0 )
+ opencc? ( app-i18n/opencc:= )"
+
+DEPEND="${RDEPEND}
+ virtual/libintl
+ virtual/pkgconfig"
+
+src_prepare() {
+ if use boost; then
+ cp "${DISTDIR}/boost.${BOOST_M4_GIT_VERSION}.m4" "m4/boost.m4" \
+ || die "copying newer version of boost.m4 file failed"
+ fi
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-english-input-mode \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable opencc)
+}